[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: octave from mercurial: make fails

From: Kjetil brinchmann Halvorsen
Subject: Re: octave from mercurial: make fails
Date: Fri, 8 Nov 2013 14:19:03 +0100


did so, ./bootstrap

but it still fails, with:

libtool: link: ranlib parse-tree/.libs/libparser.a
libtool: link: `octave-value/octave_value_liboctave_value_la-ov-re-mat.lo'
is not a valid libtool object
make[3]: *** [octave-value/] Error 1
make[3]: *** Waiting for unfinished jobs....
libtool: link: ( cd "parse-tree/.libs" && rm -f "" && ln
-s "../" "" )
libtool: link: ranlib parse-tree/.libs/libparse-tree.a
libtool: link: ( cd "parse-tree/.libs" && rm -f "" &&
ln -s "../" "" )
mv -f corefcn/.deps/corefcn_libcorefcn_la-getgrent.Tpo
mv -f corefcn/.deps/corefcn_libcorefcn_la-gcd.Tpo
mv -f corefcn/.deps/corefcn_libcorefcn_la-data.Tpo
make[3]: Leaving directory `/home/kjetil/gnuoctave/octave/libinterp'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/kjetil/gnuoctave/octave/libinterp'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/kjetil/gnuoctave/octave'
make: *** [all] Error 2

(OK, it says above : MAKE .... WAiting for unfinished jobs ...
so it could be a problem with parallell make (make -j6)
but trying again with only make,
it still fails withe errors above.


On Fri, Nov 8, 2013 at 1:50 AM, Mike Miller <address@hidden> wrote:
> On Thu, Nov 7, 2013 at 23:21:57 +0100, Kjetil brinchmann Halvorsen wrote:
>> I am on Lubuntu 13.10
>> (all of this worked some few days ago)
>> Just made hg pull & hg update
>> ./configure
>> make
>> stops with this message:
> You probably need to re-run ./bootstrap. I typically run "ls -lrt"
> after updating, and if any of, bootstrap, or
> bootstrap.conf are near the bottom and have recent timestamps, I run
> ./bootstrap.
> HTH,
> --
> mike

reply via email to

[Prev in Thread] Current Thread [Next in Thread]