[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PCRE supposedly no UTF support

From: ahowe42
Subject: PCRE supposedly no UTF support
Date: Tue, 29 Oct 2013 02:30:28 -0700 (PDT)

Hello all.  I've recently upgraded from Octave 3.4.3 to 3.6.4, and installed
the Java 1.2.9 package.  I'm on Ubuntu 12.04 (precise).Something in the
questdlg function (I think) is giving me this error which completely stops
Octave (need 3 Ctrl+C's to exit to console): /(octave:30442): GLib-CRITICAL
**: PCRE library is compiled without UTF8 support/.  I did not have this
issue before I upgraded Octave.  I found, via pcretest, that my libpcre was
still on 8.21 with no UTF8 support.  I then followed  the instructions here
<>   to
compile and install PCRE 8.33.This didn't work entirely as advertised, as I
ended up with two sets of pcretest/pcregrep (/usr/bin and /usr/local/bin),
and two sets of libpcre*.* (/usr/lib and /lib).  Running pcretest from the
console got me to the 8.21 version, but if I used the full path
/usr/bin/pcretest, I got the expected 8.33.  I solved this by overwriting
/usr/local/bin/pcretest (and pcregrep) with links to the /usr/bin version. 
Now, when I run pcretest with no path from the console, it picks up the
correct version with UTF8 support.However, I still get the same error in
Octave.  As far as I can see (and I'm very far from a Linux expert), the
issue is in Octave not calling the correct version of libpcre.  How can I
fix this?Thanks, Andrew

View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]