[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Newbie problem running *.m files on Octave 3.4.2 on Snow Leopard

From: Jordi Gutiérrez Hermoso
Subject: Re: Newbie problem running *.m files on Octave 3.4.2 on Snow Leopard
Date: Sat, 30 Jul 2011 20:56:56 -0500

On 30 July 2011 20:41, John Helly <address@hidden> wrote:
> I've put /Applications/ in my path and
> aliased octave='Octave' and I can start 'octave' from the Terminal
> command-line but whether I give it a *.m filename or not it always
> opens up an interactive session.

What did you type, what was the exact output? I find it odd that if
you type "octave -q foo.m", you end up in an interactive session, if
this is indeed what you're doing.

> I've also tried building octave-3.4.2 but it fails with a flex
> problem in that seems to be an old problem and I can't
> figure that out.

Can you say what the problem is? Just post the error messages you see.

> I then tried building from the source gotten from
> hg clone
> but that doesn't seem to have configure bundled with it.

These are developer sources and not recommended unless you want to
help with Octave's development itself. You have to build your own
configure script using GNU autotools if you want to work from the hg
sources. If you have installed autotools (and git, and probably many
many other things), do "./" to produce a configure script.

- Jordi G. H.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]