[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: addpath, undefined functions

From: Summers, Peter
Subject: RE: addpath, undefined functions
Date: Thu, 14 Jul 2011 15:31:42 +0000

From: address@hidden address@hidden on behalf of William Krekeler address@hidden
Sent: Wednesday, July 13, 2011 10:05 AM
To: address@hidden
Subject: RE: addpath, undefined functions

-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Summers, Peter
Sent: Tuesday, July 12, 2011 8:00 PM
To: address@hidden
Subject: RE: addpath, undefined functions

Ok, I've made some progress on this but now I have a really basic question.

First to recap: I downloaded some matlab files, put them in a directory (first 
within octave, then outside), pointed to them with addpath, and octave doesn't 
see them. They show up with "dir" and "edit", and are definitely where they're 
supposed to be. I'm working under windows 7 and there are no 
administrator-privilege issues (unless they're buried). I've checked pathnames 
etc for typos (none), and there are no errors that I can see in the downloaded 

Philip's suggestion of a 'test' program, and the fact that it worked (apart 
from conflicting with an internal octave command) gave me an idea. I opened 
'coher.m' (one of the afore-mentioned files), opened a new file in notepad++, 
copied coher.m verbatim into the new file, saved it under a new name ('new.m' 
-- after changing the name in the 'function' command), and gave it a try.

It worked! It calls another of my downloaded functions and I get the same 
'undefined' error on that line, but now octave is clearly seeing a function 
that's been there all along. I need to do this for every one of my (9,372) matlab files in order for 
octave to be useful to me????

I'm a user of matlab, potentially of octave. I can program pretty well in that 
environment, but am clueless when it comes to getting into the underlying 
structure (c++, java, whatever). And I'm just getting used to Win 7. So does 
this sound like something other than a trivial glitch?

Help-octave mailing list


>First, the listserv administrators prefer that we don't top post in responses. 

My bad. My frustration level was pretty high at the time.

>Now, on to your problem. You are in Windows 7 and claim that there are no 
>permission issues, but you also stated that all new files work and the files 
>that don't work were downloaded functions. If the downloaded functions were 
>downloaded by a different userid on >an ntfs partition and then copied to a 
>folder controlled by your userid then you may in fact be in 'windows 
>permissions hell.' There may also be other ways to enter this circular logic 

>I experienced a similar problem when migrating from XP to win7. Windows 7 said 
>I owned the files but then wouldn't let me access them even when operating as 
>the administrative user because the underlying numeric id for the username was 
>associated with the >windows xp username not the windows 7 username of the 
>same name. This results in behavior similar to what you are reporting, some 
>programs allow you to see and edit files, others won't because they fail to 
>escalate their process permission to the appropriate level >to access the file.

>You may find some of the following suggestions and information useful for 
>fighting permissions issues associated with access control lists in windows 7. 
>Warning take the time to understand the implications of the following 
>suggestions as they may not be appropriate >for you security environment.

I was wondering if it might be something like this. I gave myself full control 
over the relevant directories in the "properties" dialog, but it looks like 
that wasn't enough. I'll look over the links you sent and report to the list if 
I make any progress. One clarification -- I''m working on a new laptop that 
came with win7, so there won't be any issues relating to upgrading from XP.

Help-octave mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]