[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help with Excel IO - Ecel/COM not working, no Java support found

From: Jim McF
Subject: Help with Excel IO - Ecel/COM not working, no Java support found
Date: Wed, 6 Jul 2011 21:34:03 -0700 (PDT)

Hi, I am Octave newbie with an Excel IO and/or Java issue. I installed
version 3.4.0 using cygwin on a Windows Vista (ugh) computer. 

I am getting an error on an xlsread function even after installing the
io-1.0.14 package.

I also tried installing the java-1.2.8 package, but that led to a series of

Any thoughts on what the issue is and suggestions on what I might try next
would be greatly appreciated.


octave:1> bootstrap_implementation
Looking for supported interfaces:
Excel/COM... not working.
error: No Java support found.
error: called from:
error:   /home/Jim/octave/io-1.0.14/xlsopen.m at line 395, column 1
error:   /home/Jim/octave/io-1.0.14/xlsopen.m at line 168, column 15
error:   /home/Jim/octave/io-1.0.14/xlsread.m at line 188, column 6
error:   /home/Jim/bootstrap_implementation.m at line 23, column 3

After getting that error, I tried to install the package java-1.2.8.tar.gz
That led to a series of errors shown below.

octave:2> pkg install java-1.2.8.tar.gz
g++: unrecognized option '-no-undefined'
/usr/lib/gcc/i686-pc-cygwin/4.3.4/../../../../i686-pc-cygwin/bin/ld: cannot
/usr/lib/gcc/i686-pc-cygwin/4.3.4/../../../../i686-pc-cygwin/bin/ld: cannot
collect2: ld returned 1 exit status
configure: error: Could not run /usr/bin/mkoctfile-3.4.0
the configure script returned the following error: checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.exe
checking for suffix of executables... .exe
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for mkoctfile... /usr/bin/mkoctfile-3.4.0
error: called from `pkg>configure_make' in file
g.m near line 1320, column 9
error: called from:
error:   /usr/share/octave/3.4.0/m/pkg/pkg.m at line 783, column 5
error:   /usr/share/octave/3.4.0/m/pkg/pkg.m at line 354, column 9

View this message in context:
Sent from the Octave - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]