[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "printing" graphics files through aquaterm on an Apple

From: Liam Groener
Subject: Re: "printing" graphics files through aquaterm on an Apple
Date: Fri, 01 Jul 2011 16:50:34 -0700

On Jul 1, 2011, at 2:17 PM, Obed Sands wrote:

> I use Octave for a lot of data analysis, statistical analysis of data etc. I 
> frequently make graphics files using Octave. Lots of them. Bar charts, line 
> graphs, pseudo color (viz specgram) etc. Octave's graphics come out on the 
> Apple looking great through auquaterm. 
> However, I've been frustrated for some time now with the creation of graphics 
> files as provided by ghostscript using the "print" command in Octave.  If I 
> use a format such as pdf or svg the files can be enormous, if I use jpg then 
> the characters are tiny and I can't rescale them--or if I manage to rescale 
> them then the characters end up running into the graphics or the axis label. 
> Inserting them in documents is always a challenge. The graphics usually come 
> out jaggy or washed out. I've tried all different combinations of -dpdf, 
> -djpg, -deps -FTimes-Roman, etc. I usually get a message that indicates that 
> they font I'm trying to use is no good.
> But if I simply use the "save as" feature of aquaterm then all is well. The 
> graphics file that aquaterm makes look as great coming out of the files 
> they're stored in as as they do when first rendered on the screen. pdfs, 
> jpegs, whatever, they all seem to do well. I can insert them in files, print 
> them out, rotate and, generally, abuse them and they always do fine. The 
> problem is that I make so many graphics that I'm wearing out mice (and my 
> patience) generating the graphics files one at a time with aquaterm. The 
> clik-o-rama that I have to do is error prone and frutstrating. 
> So here's my question(s): 
> 1) Is there some way, in octave to "print" so that aquaterm renders the 
> graphics files (instead of GS)? 
> 2) If no, then is there any plan to 'fix' the rendering of graphics by GS or 
> to get it so that it works and plays better with the Apple? The version of GS 
> that I've got is 9.02 (dated 2011-03-30) and so I don't think that my problem 
> is that I've got an outdated GS.
> 3) Is there any other hope for me? While I would, personally, prefer it, 
> going to linux is just not an option for me. 

I just experimented a bit using a simple plot, but with a variable number of 
points plotted so the file sizes would be different. I'm using Octave 3.4.2 and 
OSX10.6.8. I tried both the gnuplot and fltk backends. I printed with the 
print <filename>.pdf and print <filename>.jpg. With the gnuplot backend, I also 
saved the file from AguaTerm as a pdf. (The only options AquaTerm gave me were 
pdf and eps.) The pdf file sizes I got, of course, varied with the number of 
points plotted. The order of file sizes among the three options (aquaterm, 
gnuplot, and fltk) varied with the number of points. With a hundred points the 
Aquaterm file was the biggest and the fltk file the smallest. With 10,000 
points the fltk file was the largest and the gnuplot file the smallest. 
However, the file sizes for a same number of plot points were always 
comparable, within a factor of 2/3.

To my tastes, the pdf's generated by Aquaterm and fltk were equally good 
looking. The gnuterm generated file was certainly acceptable, but the font used 
was changed from the displayed figure and didn't look as nice to me. I don't 
know why this should be true. The jpgs looked pretty much the same as the 
displayed files.

I guess the only thing I can conclude from all of this is that you add fltk to 
your experiments. By the way, once you have plotted with gnuplot, it's hard to 
change to fltk without restarting octave (maybe a bug?).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]