[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

problems getting octave to plot on Mac? Maybe I have solution....

From: Jonathan Kane
Subject: problems getting octave to plot on Mac? Maybe I have solution....
Date: Tue, 15 May 2007 22:40:15 -0700 (PDT)

I recently posted my problem on the list about Octave not plotting.  I have an Intel Mac Mini.  To get it working I believe you need to do the following:

1) Go to

and download and install the binaries for Octave.  Follow the links and do the same for gnuplot 4.0.0 and Aquaterm.

2) Gnuplot 4.0.0 is expecting aquaterm 1.0.0 and won't work with 1.0.1.  It can't find some libraries.  I tried removing 1.0.1 and installing 1.0.0, but the installer for 1.0.0 didn't want to install, even though I had removed all relevant files (or so I thought).  A better way around this problem is to type the following command:
sudo ln -s /usr/local/lib/libaquaterm.1.0.1.dylib /usr/local/lib/libaquaterm.1.0.0.dylib
At this point gnuplot and aquaterm should work together.  You can test that.  Check the gnuplot page for the appropriate commands.

Octave was still giving me trouble and showing errors when it started up (and would not plot).  I BELIEVE the following was what I did to get that fixed:

3) Install the Mac OS X cd that came with your mac.  Do a search for 'X11' on the CD.  You should find "X11User.pkg".  There are apparently some X11 libraries that are needed, but not automatically installed on a Mac.  Install them.

4) Finally append the following command to the .bash_profile file (create it if it doesn't exist):
export AQUATERM_PATH=/Applications/
export PATH=$PATH:/usr/local/bin
export GNUTERMAPP=/Applications/
export GNUTERM=aqua

I got all this information from various locations on the net.  I am an amateur so I don't really understand it, but it worked and I am up and running.

I hope this helps someone.

Good luck!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]