[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Enabling SuiteSparse support during compile (Linux)

From: Theo. Sean Schulze
Subject: Enabling SuiteSparse support during compile (Linux)
Date: Sun, 01 Apr 2007 16:05:32 +0200
User-agent: Thunderbird (X11/20070221)


I compiled octave 2.9.10 the other day on my slackware linux box, but
when I did the tests, I got a number of failures, many of which were
with sparse matrix functions.  So, I went to the trouble of getting the
SuiteSparce and its dependencies GotoBLAS, LAPACK, and metis.  I
compiled them all.  Install was not really that straight forward for me,
because I am used to software packages that copy the libraries created
to /usr/local/lib/ when I run `make install`.  I ended up copying
several of the lib*.a files to /usr/local/lib by hand, but for the most
part, at least up to compiling SuiteSparse, it seemed to work.

I am frustrated now though, because despite the fact that I copied every
*.a file I could find in the SuiteSparse package to both directly into
/usr/local/lib and into the /usr/local/lib using the subdirectory
structure that occurs in the SuiteSparse source directory (./AMD/,
./BTF/, etc.), configure still can not find the libraries or header
files it is looking for.  I have even copied the entire SuiteSparse
source directory into the octave source directory, but that hasn't
worked either.

Clearly there is something about the compiling and installing process
that I don't understand, and I would be grateful for some pointers on
what I am doing wrong.

BTW, is it standard among mathematical packages that `make install` just
leaves the files resulting from the compile in the source directory?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]