[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MEX compilation problem---error: `xyz' undefined

From: Paul Kienzle
Subject: Re: MEX compilation problem---error: `xyz' undefined
Date: Fri, 30 Mar 2007 04:24:45 -0400

On Mar 29, 2007, at 9:00 PM, Steve C. Thompson wrote:

On Thu, 2007-03-29 at 20:26 -0400, Paul Kienzle wrote:
At a guess I would say that you are not linking to the
interleaver library.

You can use "ldd CreateUmtsInterleaver.oct" to see what
libraries it depends on and "nm CreateUmtsInterleaver.oct"
to see what symbols it is missing.

Here's what I get:


I don't see any missing symbols.

These lines look suspicious: => not found => not found => not found

By the time your octfile needs them they are already loaded.

I have those libraries on my computer, of course.  I tried the

  1) Add /usr/local/octave/2.9.10/lib/octave-2.9.10/ to my path
  2) recompile with mkoctfile (see no compile errors)
  3) repeat ldd and nm commands (get the same thing, same problem
                                 in Octave too)

You would need to add this line to /etc/ and run
ldconfig in order for ldd to see them.  Don't do it though
since octave takes care of loading them for you.

This didn't work.  I then tried


Any ideas?


        - Paul

reply via email to

[Prev in Thread] Current Thread [Next in Thread]