[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bode, "arguments must be scalars" error

From: Norm Hecht
Subject: Re: bode, "arguments must be scalars" error
Date: Tue, 13 Mar 2007 18:23:29 -0600


I tried your example on my Intel Mac running Octave 2.9.9, and
it worked like it was supposed to, giving me a correct Bode diagram.
So it will work on some machines--does  anyone know what to check
to track this bug down?

Norm Hecht

On Mar 13, 2007, at 10:52 AM, Guido Mureddu wrote:

Hello, I'm not sure whether this is the correct place to post this, so excuse me if it isn't. I'm currently using Octave 2.1.73, on Linux. I'm trying to get the bode plot of the simple transfer function 1/s.
I try to accomplish this in this way:

| octave:1> G = tf(1, [1 0])
| octave:2> sysout(G)
| Input(s)
|       1: u_1
| Output(s):
|      1: y_1
| transfer function form:
| 1
| ---------
| 1*s^1 + 0

Which seems to be correct. However, when I try to plot it using the bode function, it produces this error:

| octave:3> bode(G)
| error: logspace: arguments must be scalars
| error: evaluating if command near line 85, column 3
| error: called from `logspace' in file `/usr/local/share/octave/ 2.1.73/m/general/logspace.m'
| error: evaluating assignment expression near line 78, column 9
| error: evaluating if command near line 67, column 5
| error: called from `__freqresp__' in file `/usr/local/share/ octave/2.1.73/m/control/base/__freqresp__.m' | error: called from `__bodquist__' in file `/usr/local/share/ octave/2.1.73/m/control/base/__bodquist__.m' | error: called from `bode' in file `/usr/local/share/octave/2.1.73/ m/control/base/bode.m'

What am I doing wrong? My Linux distribution (Ubuntu 6.06) has a precompiled package of Octave 2.1.72, so I removed it and compiled 2.1.73 hoping it would solve it, but unfortunately, no such luck.

Thanks for your help,

Guido Mureddu
Help-octave mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]