[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Octave 2.1.73 installation problem

From: Guan, Yun
Subject: Octave 2.1.73 installation problem
Date: Fri, 22 Dec 2006 23:34:26 -0600 (CST)
User-agent: SquirrelMail/1.4.5

Hi, everyone

Recently, I tried to install Octave 2.1.73 in my own account on a Debian
server. There was an error message(at the end of this email) after " make
CFLAGS=-O2 CXXFLAGS=-O2". But, I still tried "make install". Looked like
it went well. I can check the installation destination directory, but
there is no octave binary in bin directory. Does anyone know what the
problem is? I am wondering whether I have to be a superuser to do the


make[3]: Entering directory `/huis/yun/Downloads/octave-2.1.73/doc/faq'
dvips -o Octave-FAQ.texi
This is dvips(k) 5.86e Copyright 2001 Radical Eye Software
dvips: ! Bad DVI file: first byte not preamble
make[3]: [] Error 1 (ignored)
g++-3.3 -c  -fPIC -I. -I.. -I../liboctave -I../src -I../libcruft/misc 
-DHAVE_CONFIG_H -mieee-fp -Wall -W -Wshadow -O2 -o
pic/oct-fstrm.o In constructor `octave_fstream::octave_fstream(const
   std::string&, std::_Ios_Openmode, oct_mach_info::float_format)': error: no matching function for call to `
   std::basic_fstream<char, std::char_traits<char> >::open(const char*,
   std::_Ios_Openmode&, int)'
/usr/include/c++/3.3/fstream:815: error: candidates are: void
   std::basic_fstream<_CharT, _Traits>::open(const char*, std::_Ios_Openmode)
   [with _CharT = char, _Traits = std::char_traits<char>]
make[2]: *** [pic/oct-fstrm.o] Error 1
make[2]: Leaving directory `/huis/yun/Downloads/octave-2.1.73/src'
make[1]: *** [src] Error 2
make[1]: Leaving directory `/huis/yun/Downloads/octave-2.1.73'
make: *** [all] Error 2

reply via email to

[Prev in Thread] Current Thread [Next in Thread]