[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave 2.9.9 + Octave-Forge 2006.07.09 on x86 MAC OS X 10.4.8 Tiger

From: Joe Koski
Subject: Re: Octave 2.9.9 + Octave-Forge 2006.07.09 on x86 MAC OS X 10.4.8 Tiger
Date: Sat, 16 Dec 2006 11:20:22 -0700
User-agent: Microsoft-Entourage/

on 12/15/06 5:41 AM, Paul Koufalas at address@hidden wrote:

>> G'day all.
>> I'm trying to get Octave + Octave Forge running on my new MacBook
>> Pro Core 2 Duo (x86) running OS X 10.4.8 (Tiger)
>> I installed the binary Octave 2.9.9 from the HPC project without
>> much trouble at all.  I then tried to install the binary Octave-
>> Forge from the HMUG site and am having trouble getting it to work.
>> Not sure if it's something simple (path problem), Mac specific (X11
>> issue) or nefarious.

First, I am not a developer, but rather an octave user. I have a "built from
source" octave-2.9.9 installed on my Mac G5 with OS X 10.4.8. I am using
(with some patches) octave-forge-2006.07.09, and it does everything that I
need, but it is not completely functional, especially in some image related
areas. Octave is currently in a transition period waiting for a new
octave-forge package system, and some improvements to the gnuplot interface,
so some special temporary measures are probably in order.

As I recall, the HMUG installer is different from the HPC installer.
Basically, the HMUG installer is the "sudo make install" portion of the
octave-forge build, while the HPC installer copies the binary structure from
a tar file into /usr/local. The HMUG approach is more dependent on what else
is installed on the machine (libraries, etc.), so I'm not surprised that
they two approaches are not completely compatible.

My suggestion for an interim solution, assuming that you have Xcode-2.4
Developer Tools installed, would be to install gfortran from the HPC site
and attempt to build octave-forge-2006.07.09. If mkoctfile functions
properly, you should be able to build and install a compatible octave-forge.
Once it is working properly, the octave-forge build only takes a few

Otherwise, the fallback is to go back to octave-2.1.73 and it's associated
octave-forge from Fink or MacPorts until octave is through the transition.

Any other ideas?


>> From having what looked to be a working Octave 2.9.9, this is what
>> I get when I run Octave now:
>> GNU Octave, version 2.9.9 (i386-apple-darwin8.8.1).
>> Copyright (C) 2006 John W. Eaton.
>> This is free software; see the source code for copying conditions.
>> FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.
>> Additional information about Octave is available at http://
>> Please contribute if you find this software useful.
>> For more information, visit
>> Report bugs to <address@hidden> (but first, please read
>> to learn how to write a helpful
>> report).
>> error: couldn't link module /usr/local/libexec/octave/2.9.9/site/
>> oct/i386-apple-darwin8.8.1/octave-forge/gf.oct
>> error: evaluating argument list element number 2
>> error: near line 24 of file `/usr/local/share/octave/2.9.9/site/m/
>> octave-forge/comm/PKG_ADD'
>> error: source: error sourcing file `/usr/local/share/octave/2.9.9/
>> site/m/octave-forge/comm/PKG_ADD'
>> error: near line 11 of file `/usr/local/share/octave/2.9.9/m/
>> startup/octaverc'
>> octave:1> randint(2,2,2)
>> ans =
>>    1   0
>>    1   1
>> octave:2> which randint
>> randint is the user-defined function from the file
>> /usr/local/share/octave/2.9.9/site/m/octave-forge/comm/randint.m
>> octave:3> which gf
>> error: couldn't link module /usr/local/libexec/octave/2.9.9/site/
>> oct/i386-apple-darwin8.8.1/octave-forge/gf.octwhich: `gf' is the
>> script file
>> /usr/local/libexec/octave/2.9.9/site/oct/i386-apple-darwin8.8.1/
>> octave-forge/gf
>> octave:3>
>> ===
>> When I remove all of the Octave-Forge directories, Octave looks ok
>> again.  Any help / advice with this is much appreciated.
>> Cheers,
>> Paul

reply via email to

[Prev in Thread] Current Thread [Next in Thread]