[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave won't plot on Mac OS X

From: Norm Hecht
Subject: Re: Octave won't plot on Mac OS X
Date: Thu, 5 Jan 2006 22:00:41 -0700 (GMT-07:00)

Still no luck on getting Octave plotting or even gnuplot to work.

I added two lines to my .tcshrc file for GNUTERM and DISPLAY,
so now it's 

setenv PATH /opt/local/bin:opt/local/sbin:/usr/local/mysql/bin:$PATH
setenv GNUTERMAPP /Applications/DarwinPorts/
setenv GNUTERM aqua
setenv DISPLAY 0.0

When I log into gnuplot, it gives the message "Unknown or ambiguous 
terminal name 'aqua'".  Typing "set terminal" shows that yep, no sign 
of aqua on the list, nor any variation on aqua.  I get the same error 
when I try plotting in Octave itself.  Do I need to get an updated/modified 
version of gnuplot that deals with aqua?

Thanks again for helping!


-----Original Message-----
>From: Joe Koski <address@hidden>
>Sent: Jan 4, 2006 4:42 PM
>To: Norm Hecht <address@hidden>, Octave Help <address@hidden>
>Subject: Re: Octave won't plot on Mac OS X
>In my .bash_profile, I have the lines
>export GNUTERM=aqua
>export DISPLAY=:0.0
>Do you have the setenv equivalents in your .tcshrc?
>on 1/4/06 4:14 PM, Norm Hecht at address@hidden wrote:
>> Hello,
>> I just installed Octave from DarwinPorts, and both Octave and gnuplot
>> will run, but won't actually plot.  I give the commands, but no plot
>> window appears.  I have AquaTerm installed as well, also from DarwinPorts.
>> I've edited my .tcshrc file to include the line
>> setenv GNUTERMAPP /Applications/DarwinPorts/
>> What else can I try?
>> Here are the versions I'm using:
>> Mac OS X 10.3.9
>> Octave 2.1.71
>> Gnuplot 4.0, patch level 0
>> Darwin 7.9
>> AquaTerm 1.0.b2
>> Thanks for your help!
>> Norm Hecht
>> Colorado

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]