[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest build problems with octave and OS X

From: Marius Schamschula
Subject: Re: Latest build problems with octave and OS X
Date: Sat, 18 Dec 2004 13:23:05 -0600


This my configure command for octave 2.1.64 (non ATLAS version):

FLIBS='-L/usr/local/lib/ -lg2c' LIBS='-lsz' CPPFLAGS=-no-cpp-precomp ./configure \
 --enable-dl --enable-shared --with-hdf5 --with-fftw

Note: You may not have fftw or hdf5 (which requires szip).

See <> for more details.

On Dec 18, 2004, at 9:25 AM, Joe Koski wrote:

on 12/17/04 9:20 PM, Paul Kienzle at address@hidden wrote:

It looks like you are missing the fortan libraries. Try something like

LIBS=-lf2c ./configure


LIBS=-lg2c ./configure

Someone with a more recent version of XCode can give you better advice.

- Paul

Thanks for the suggestions. OK, so far I have tried

LIBS=-lf2c ./configure

And it goes through all of the g++ compilations before it fails, but I
suspect that it is compiling a statically linked version, which I don't
want. The libf2c.a is in /usr/local/lib because I have f2c installed on my
machine. It wouldn't exist on a "normal" Mac.

I have also tried (with various make file errors occurring later):

LIBS=-lg2c ./configure

LIBS=-lg2c ./configure --enable-shared --enable-dl --disable-static

LIBS=-lg2c ./configure --enable-shared --disable-static

LIBS=-lf2c ./configure --enable-shared --disable-static


Anybody have the proper etiquette for the ./configure arguments for an
octave build on a Mac?

The configure phase always finishes with a complaint that says DejaGNU isn't there, so I won't be able to run "make check," but the initial make is where
the build fails.


On Dec 17, 2004, at 10:54 PM, Joe Koski wrote:

I'm posting this to both the octave-help and the Apple unix-porting
because this type of problem straddles both camps. The original octave
file is usually done for Linux with a bash shell as a basis. Are there
ideas about how to fix the build to work on a Mac?

The build was done on OS X 10.3.6 with Xcode 1.5 and the November 2004
3.3 update installed.

In compiling the latest sourceforge version of octave-2.1.64, the Mac
fails with the following symbol problems

ld: warning multiple definitions of symbol _xerbla_
blas-xtra/xerbla.o definition of _xerbla_ in section (__TEXT,__text)
/System/Library/Frameworks/Accelerate.framework/Versions/A/ Frameworks/
.framework/Versions/A/libBLAS.dylib(single module) definition of
ld: Undefined symbols:
/usr/bin/libtool: internal link edit command failed
make[3]: *** [libcruft.dylib] Error 1
make[2]: *** [libraries] Error 2
make[1]: *** [libcruft] Error 2
make: *** [all] Error 2

_xerbla is apparently the BLAS error handler routine. Also, what
library is
missing for the other routines on the Mac? What other library is
needed? How
do we tell the Mac version to use the native Mac stuff?

Thanks for any help.


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]