[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

linking to ATLAS threaded ptcblas and ptf77blas libraries

From: E. Joshua Rigler
Subject: linking to ATLAS threaded ptcblas and ptf77blas libraries
Date: Sat, 02 Oct 2004 14:25:22 -0600

I installed ATLAS libraries and headers in the non-standard directories
(no root access):


I then use the following configure invocation:

>> LDFLAGS="-L/home/username/local/lib" 
>> CPPFLAGS="-L/home/username/local/include ./configure --other-options

I'm mostly certain thatall the proper libraries are being found, since
rather than just "-llapack -lblas", I get the following once configure
is finished:

  BLAS libraries:       -llapack -lcblas -lf77blas -latlas

What I *really* want is to link to the posix threaded versions of the
ATLAS libraries (i.e., libptcblas.a and libptf77blas.a).  Is it even
possible or desirable to link to multi-threaded libraries with Octave,
and if so, are there special compiler flags I should be aware of (I run
on a 2-CPU amd64 RHEL-3 linux machine)?

For what it's worth, I tried simply changing the names of my
libptcblas.a and libptf77blas.a libraries to libcblas.a and
libf77blas.a, respectively.  Octave's configure script apparently didn't
like these though, and simply reverted to my system's default

Thanks for any help.


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]