[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with 2.1.57 loading Octave binary format data file

From: Glenn Golden
Subject: Re: Problem with 2.1.57 loading Octave binary format data file
Date: Thu, 01 Apr 2004 10:37:28 -0700

David Bateman writes:
> Another thing is that the code that does the saving is now distributed
> into the classes of the octave_values themselves. Therefore the situation
> might be different if you save a complex_matrix, bool_matrix, or struct.
> Could you try each individually?

OK, tried them all, they all fail the same way.

> You can have multiple compilers installed, so I'm not sure I see that
> problem.

I didn't mean to make it sound like it's a fundamental problem, it's
just the usual dependency-hell. By way of example: I just picked up
gcc 3.3.3 tarball... but it requires a recent binutils. There's no 
RPM for that version of binutils for 7.3, so I have to install that
from source too. But binutils is not a trivial package to install from
sources, because, among other things, it requires doing an rpm --erase
on the existing binutils, which temporarily leaves one without a working
ld... etc., etc.

Of course these are just annoyances and can be worked. My whine
was just that when one is hard pressed for time, doing a source
install of a new gcc version is a far cry from "rpm -Uih gcc-x.x.x.rpm",
which I've become spoiled with. 

> Have you compiled other recent versions?

A few CVS snapshots post-2.1.50, but not since several months ago,
at least.

> The issue is that JWE added
> the -Wshadow flag to the compile, which wasn't there before. Most of
> the shadowing issues aren't important, and are in fact build dependent.
> They aren't important, at least not the ones you see in 2.1.57.

OK, thanks.

Btw -- change of subject -- when I was rebuilding 2.1.57 on my other
machine, I hadn't noticed it was low on disk space in that partition,
so the make aborted due to no space left, just before the final link.
But when I cleaned up the disk and restarted the make, I was surprised
to find that it did not proceed down to doing the final link, but
re-ran what seemed like a large number of compiles.  Are there intentional
forced dependencies in the makefile which cause object rebuilds like this
even though (presumably) not warranted by predecessor age?  (If it's not
intentional, just let me know and I'll file a formal bug report on it
with more detail.)


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]