[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Known ATLAS+gcc3.2 Issue (was ATLAS with the latest cygwin)

From: Randy Gober
Subject: Known ATLAS+gcc3.2 Issue (was ATLAS with the latest cygwin)
Date: Sun, 12 Jan 2003 07:00:13 -0600

You may wish to (clearing throat) "re" read the errata file.

Here is the link to the full errata file, with a pointer to this issue.=20 , or you could just
read the text below...

Cygwin's default gcc won't work, must use gcc-2
If you try to install with cygwin's default gcc, the ATLAS install will die
almost immediately. The fix is to use gcc 2.95 rather than gcc 3. Run config
as normal to create your Make.ARCH file. In your Make.ARCH file, change the
F77 to reference g77-2, rather than g77. Then, edit the macros GOODGCC, CC,
MCC, XCC, and change gcc to gcc-2. If you have previously tried to install
with the bad compilers, restart from scratch as explained here. Otherwise,
simply start the install as normal.

Also, you should also look at the errata file for dealing with the two
issue-links below.

Good, luck..



On Wed, 8 Jan 2003 address@hidden wrote:
> I haven't been able to compile the ATLAS 3.4.1 with the latest cygwin gcc
> (3.2). Although it is not a requirement for my ofw package a lot of people
> requested it. I tried the atlas support tracker with no luck. Any of the 
> people
> that is currently working on ofw (with any package) can give a hand?

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]