[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

install problems - RH 8, octave-2.1.36, gcc 3.2

From: Richard Morey
Subject: install problems - RH 8, octave-2.1.36, gcc 3.2
Date: 17 Oct 2002 22:56:47 -0500

I am trying to install octave 2.1.36 on a redhat 8.0 system with gcc
3.2. It configures fine, but when I run make it exits with the following

g++ -c  -I. -I.. -I../liboctave -I../src -I../libcruft/misc  -I../glob
-I../glob -DHAVE_CONFIG_H -mieee-fp -g -O2 -Wall -o
In file included from
c-file-ptr-stream.h: In constructor
`c_file_ptr_buf::c_file_ptr_buf(FILE*, int
c-file-ptr-stream.h:56: no matching function for call to `
   std::basic_filebuf<char, std::char_traits<char>
/usr/include/c++/3.2/iosfwd:83: candidates are: std::basic_filebuf<char,
   std::char_traits<char> >::basic_filebuf(const
   std::char_traits<char> >&)
   _Traits>::basic_filebuf() [with _CharT = char, _Traits =
make[2]: *** [c-file-ptr-stream.o] Error 1
make[2]: Leaving directory `/home/morey/octave-2.1.36/src'
make[1]: *** [src] Error 2
make[1]: Leaving directory `/home/morey/octave-2.1.36'
make: *** [all] Error 2

I saw this error in a previous post,
but the solution, editing config.h, was unnecessary because the config.h
was already in the state which the poster suggested.

Also, I tried getting the CVS version, but there was no configure script
with it! Is that normal? I am new to the CVS thing.


Richard Morey
Graduate Research Assistant, Cognition and Neuroscience
University of Missouri-Columbia

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]