[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with load()-function after upgrade

From: John W. Eaton
Subject: Problems with load()-function after upgrade
Date: Thu, 19 Sep 2002 11:02:09 -0500

On 19-Sep-2002, Andrass Ziska Davidsen <address@hidden> wrote:

| After I upgraded to octave-2.1.36, the load()-funtion gives errors.
| I downloaded the octave-2.1.36-4mdk.i586.rpm from and 
| tried to install it. I had to install:
| libf2c0-3.2-1mdk.i586.rpm
| libhdf5_0-1.4.2p1-2mdk.i586.rpm
| readline-4.3-4mdk.i586.rpm
| in order to fulfill dependencies.
| It all went well.
| But when I now try to load ascii-data where some of the fields are the 
| special value 'inf' following error occurs:
| load 'test1.dat'
| error: load: failed to read matrix from file `test1.dat'
| this is annoying, as it worked prior to the upgrade.
| Is there a workaround or some setting, that I've missed?

I don't think this has ever worked on all systems, because Octave uses
the system C/C++ library to read numbers, and not all of them handle
reading "Inf", "NaN", etc.  If you want to reliably read special
values like this, it's best to use a binary format.


Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]