[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: Suggestion: add do-enddo(condition)
From: |
A. Scottedward Hodel |
Subject: |
Re: Suggestion: add do-enddo(condition) |
Date: |
Thu, 27 Jan 2000 07:59:40 -0600 |
User-agent: |
Microsoft Outlook Express Macintosh Edition - 5.01 (1630) |
> on 1/27/00 4:33 AM, Thomas Walter at address@hidden wrote:
>>>>>> "John" == John W Eaton <address@hidden> writes:
simpler to write loops for fitting and similar things.
>
> John> I don't recall seeing any responses to this message, so maybe there
> John> are not very many people who have strong feelings about it one way or
> John> the other. Is anyone else interested in having this construct
> John> available in Octave?
>
> I have not seen a reply too. But having both kinds of loops can make
> the code much cleaner in some cases. And the lack of any reply may
> depend on other tools like the always referenced 'matlab' not having
> this. I do not know this package, only 'pari/gp' which comes with GPL
> (ftp://megrez.math.u-bordeaux.fr/pub/pari) , and the comercial
> package 'mupad'.
I think I just missed the original post. I've been implementing
do
x = blah()
enddo (condition)
with
x = blah()
while(condition)
x = blah()
endwhile
all the while wishing there were an easier way to do it. Writing blah() as
a function call reduces the code duplication, but isn't quite the same.
"If you build it, they will come."
Or something like that.
--
A S Hodel Assoc. Prof. Dept Elect and Computer Eng, Auburn Univ,AL
36849-5201
On leave at NASA Marshall Space Flight Center (256) 544-1426
Address until 31 July 2000:Mail Code TD-55, MSFC, Alabama, 35812
http://www.eng.auburn.edu/~scotte
-----------------------------------------------------------------------
Octave is freely available under the terms of the GNU GPL.
Octave's home on the web: http://www.che.wisc.edu/octave/octave.html
How to fund new projects: http://www.che.wisc.edu/octave/funding.html
Subscription information: http://www.che.wisc.edu/octave/archive.html
-----------------------------------------------------------------------
- Suggestion: add do-enddo(condition), John W. Eaton, 2000/01/27
- Re: Suggestion: add do-enddo(condition), Thomas Walter, 2000/01/27
- Re: Suggestion: add do-enddo(condition),
A. Scottedward Hodel <=
- Re: Suggestion: add do-enddo(condition), John W. Eaton, 2000/01/27
- Re: Suggestion: add do-enddo(condition), John W. Eaton, 2000/01/27
- Re: Suggestion: add do-enddo(condition), Johan Kullstam, 2000/01/27
- Re: Suggestion: add do-enddo(condition), Joao Cardoso, 2000/01/27
- Re: Suggestion: add do-enddo(condition), John W. Eaton, 2000/01/27
- Re: Suggestion: add do-enddo(condition), Ted Harding, 2000/01/27
- Message not available
- Re: Suggestion: add do-enddo(condition), Johan Kullstam, 2000/01/28
- Re: Suggestion: add do-enddo(condition), Francesco Potorti`, 2000/01/28
- Re: Suggestion: add do-enddo(condition), Francesco Potorti`, 2000/01/28
- Re: Suggestion: add do-enddo(condition), Johan Kullstam, 2000/01/28