[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building octave 2.0.8 and later on Linux

From: John W. Eaton
Subject: Building octave 2.0.8 and later on Linux
Date: Fri, 11 Jul 1997 12:35:33 -0500

On 11-Jul-1997, Dirk Laurie <address@hidden> wrote:

| I downloaded octave 2.0.8 with the idea of building it first,
| applying the 2.0.9 patch, and re-making.  I'm running Red Hat
| 4.1 Linux.
| Problem 1: termcap.h not found
| Solved: ln -s /usr/include/ncurses/termcap.h /usr/include/ 
| Query: since octave seems to use kpathsea, why isn't termcap.h
| found in the subdirectory?

I don't quite understand the question.  I assume gcc can't find
termcap.h when you are trying to compile some file.  I don't see what
that has to do with kpathsea.

In any case, can someone say why termcap.h isn't installed in
/usr/include on this system?

| Problem 2: ld: cannot open -lieee: No such file or directory
| Not solved; can't even identify a package offering libieee.a
| or similar.

After patching to get to 2.0.9, did you recreate the configure scripts
using autoconf and autoheader (sorry that this is not automated yet)?
If so, configure should have avoided adding -mieee-fp to the compiler
flags.  If configure still doesn't do the right thing, the
README.Linux file has a couple of other alternatives.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]