[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Experiences with octave 1.93 on DEC-Alpha

From: Peter Bruhn
Subject: Experiences with octave 1.93 on DEC-Alpha
Date: Fri, 6 Dec 1996 15:34:34 +0100


I have tried to compile the 1.93 sources on my DEC-Alpha running
DEC-UNIX 4.0 (formerly called DEC-OSF) using gcc

Compiling went fine (except for the glob-subdirectory, but I just
removed it, since the functions glob and fnmatch are in the standard
library anyway).

When I used octave, I got core-dumps whenever I tried to call a
command that does not exist. The problem was somewhere in the kpathsea
library. So I linked octave 1.93 with the kpathea library of octave
1.1.1. This seemed to work fine.

After using octave 1.93 for a while I found the following problems:

1. Calculations like 222^222 do not give "Inf" but "1.7977e+308".

2. fscanf does not work properly (not as documented and not as it
   works with octave 1.1.1

   Both fscanf(fnum, "%s") and fscanf(fnum, "%c") read the whole
   contents of a file, instead of just a word or just a character.

Any comments, hints, flames,... are appreciated,

Peter Bruhn             | Department of Applied Computer Science
                        | University of Economics and Business Administration
                        | Augasse 2-6, A-1090 Vienna, Austria
address@hidden     | Phone: +43 1 31336 x5209 fax: x739

reply via email to

[Prev in Thread] Current Thread [Next in Thread]