[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Hurd restarts immediately after grub2

From: Tony Olagbaiye
Subject: RE: Hurd restarts immediately after grub2
Date: Thu, 24 Jun 2010 22:24:46 +0100

Thus the command for booting Mach would be:

        multiboot /boot/gnumach.gz gnumach.gz root=device:?d?s?

And the attatched Hurd servers:

        module /hurd/ext2fs.static ext2fs.static --multiboot....$(task-resume)
        module /lib/ /hurd/exec exec $(exec-task=task-create)

Am I right? Because I also tried this, or a variation of this, and it yeilded the same results.

On Thu, Jun 24, 2010 at 12:05 PM, Thomas Schwinge <> wrote:

On Thu, Jun 24, 2010 at 11:48:07AM +0100, Tony Olagbaiye wrote:
> I'm not quite sure of that, I'll find out later today, but after several
> attempts I realised that it was not in fact hurd that was causing the
> problem. As soon as i tried a grub 0.97 cd and booted from there, everything
> worked fine. Does Grub2 not support the hurd multiboot yet?

It does.  But at some point, there was a change in GRUB2's multiboot
code, and everything that previously read:

   multiboot /boot/foo
   module /boot/bar arg1 arg2

... would now have to read:

   multiboot /boot/foo foo
   multiboot /boot/bar bar arg1 arg2

Can you confirm that GRUB2 is able to boot your GNU/Hurd system an
equivalent change?


Version: GnuPG v1.4.10 (GNU/Linux)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]