[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gnu hurd installation nativ-install fails.

From: Enaut Waldmeier
Subject: Re: Gnu hurd installation nativ-install fails.
Date: Mon, 22 Feb 2010 16:33:27 +0100

Ok I created a -verbose logfile of an installation process I hope that everythin is in it. I added some comments in between. ps there might be spelling mistakes in the hurdparts since i copied it manually with pen and paper.

sudo mke2fs -O none -o hurd /dev/sda5
sudo mount /dev/sda5 /media/hurd/
sudo crosshurd
    symlink to usr
error during exec of crosshurd:
I: Extracting /var/cache/apt/archives/dash_0.5.5.1-3_hurd-i386.deb...
tar: ./bin/sh: Cannot create symlink to `dash': File exists
tar: ./usr/share/man/man1/sh.1.gz: Cannot create symlink to `dash.1.gz': File exists
tar: Exiting with failure status due to previous errors

ignored... because extracting manually did not help.

reboot with: (grub2)
menuentry "GNU/Hurd single user" {
insmod ext2
set root=(hd0,5)
multiboot /boot/gnumach.gz root=device:hd0s5 -s
module /hurd/ext2fs.static /hurd/ext2fs.static --multiboot-command-line='${kernel-command-line}' --host-priv-port='${host-port}' --device-master-port='${device-port}' --exec-server-task='${exec-task}' -T typed '${root}' '$(task-create)' '$(task-resume)'
module /lib/ exec /hurd/exec '$(exec-task=task-create)'

in hurd:
export TERM=mach

errors like:
failed to flush the nscd cache
    posix_spawn() error 1073741862

timezone Data set to: Europe Berlin
default shell set to /bin/sh

tail of nativ-install:

util-linux depends on initscripts however initscripts is not configured yet...

Errors where encountered while processing initscripts.
end of ./native-install

invoking dpkg --configure initscripts manually results in:
setting up initscripts: can't exec "insserv": no such file or directory at /sbin/update-rc.d
update-rc.d: insserv rejected the script header
returned exit stat 255

on invoke of passwd:
passwd: pam_start() failed error 26

After that I tried to boot the hurd in singleusermode. but it hangs. the last message:
hurd server bootstrap: ext2fs.static [device:hd0s5] exec
init proc auth

so I cut the power(is there a more gentle way?) and booted linux and realized that the filesystem is corrupt. So i fixed it with Linux (fsck).
after that I was able to boot into multiusermode (removing the -s from grub2 options) but as mentioned in the last mail, was not able to login. and again a powercut because I can't find a clean way to shut down.

greetings FD

reply via email to

[Prev in Thread] Current Thread [Next in Thread]