[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Help compiling oskit-mach

From: Miguel
Subject: Help compiling oskit-mach
Date: Mon, 01 Sep 2003 00:14:28 +0100
User-agent: Gnus/5.1002 (Gnus v5.10.2) Emacs/21.2 (gnu/linux)

Hi everyone,

I would like someone to help me compiling the oskit-mach because I'm
getting completly mad trying to do so :)

I tried to follow the instructions that are given in the hurd-wiki site
but I think I'm doing something wrong... Here's the problem description:

I installed the Debian GNU/Linux MiG package (apt-get install
mig-i386-gnu) instead of compiling it. Then, I just checked-out the
latest version of oskit and gnumach from CVS. The first problem was to
compile the oskit. I had to apply a patch in order to be able to compile
it (thanks <someone???> from #hurd ;) ). The patch I used is in

After this, I had also to uncomment the rtl8139 driver in the
linux_ethernet.h header file because this is exactly my network
card (I hope this is a correct thing to do...).

Finally, I used the following command to configure the oskit:

CC=gcc-2.95 \
CFLAGS="-g -O2" \
configure --prefix=/home/miguel/hurd/ \
          --enable-debug \

The module file I used was the one from the hurd-wiki page. The
make/make install command were ok.

Then, I tried to configure the gnumach with:

MIG=/usr/bin/i386-gnu-mig \
CC=gcc-3.2 \
CFLAGS="-g -O2" \
OSKIT_LIBDIR=/home/miguel/hurd/lib/oskit \
configure --prefix=/gnu

The make command was:

make kernel-ide+ethernet_rtl8139

I all went ok (of corse, I did a make install :) )

When I rebooted, I saw the following:

Welcome to Gnu Mach 1.91!
kernel page fault at address 0x1, eip = 0x1
kernel page fault trap, eip 0x1
kernel trap, type 14, code = 0
dump of trape_state at 0x00299188:
EAX ...
_exit(1) called; rebooting...

Then, I tried to recompile the kernel doing only a make kernel-ide. The
same error again!

My grub entry to boot the oskit-mach is:

title           Debian Gnu/Hurd (OSKit-Mach)
root            (hd0,4)
kernel          /boot/oskit-mach.gz root=device:hd0s5
module          /hurd/ext2fs.static \
 -T typed ${root} $(task-create) $(task-resume)
module          /lib/ /hurd/exec $(exec-task=task-create)

I hope someone help me with this, as I have no experiment with kernel


P.S.: by the way, I tryed to compile the MiG from CVS but I wasn't to do
so! Is there any problem with it?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]