[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help-hurd Digest, Vol 5, Issue 18

From: Joachim Nilsson
Subject: Re: Help-hurd Digest, Vol 5, Issue 18
Date: 22 Apr 2003 17:50:16 +0200

When I got this message I found the dirty workaround "exec su" on the 
login prompt. I think GNU/Wolfgang or someone mentioned that in an
earlier message on some of the GNU mailing lists.

This obviously has something to do with the auth server, but I think
the problem is simpler than that most of the time it appears, because:

I noticed the problem often happened when I didn't shutdown the
Hurd correctly and therefore I got filesystem corruption. One time
the /etc/password and /etc/shadow files where completely out of sync.
Another time it was the /servers/password "file" that was missing[1].
And so forth.

If you do get this problem try "exec su" at login and poke around in
the /lost+found/ directory - or like I do nowadays - keep a PartImage
partition image, or a redundant Hurd installation. It helps when things
go bad[2] like this.


[1] - The Hurd password server (/hurd/password) is usually "mounted"
[2] - Once I was running an Mgp slideshow in X to demonstrate that the
Hurd actually existed and worked. On the same Hurd box I also compiled
Emacs. During the demo Mgp suddenly croaked between two slides and 
somehow got the idea to display the Emacs source code ... extremely bad!
A good reminder that not everything is all and well with the Ext2fs
server. :-)

On Tue, 2003-04-22 at 16:52, wrote:
> Huh.  I reinstalled a Hurd system this weekend and have the same
> trouble.  I tried 'ql' and 'su' with no luck.  Maybe 'su -' will get
> it but I thought I tried that too.  I was able to log in as root after
> the multiuser boot, but after some point (sorry lots of stuff going on
> and didn't notice exactly when/why).  I thought maybe I corrupted some
> authentication file or something.  I am in the middle of something
> more important to me right now (oskit/mach entropy), so I can't look
> too hard at this now, but I thought I'd mention my experience anyway.
> If I do look further I'll post...  Dmitry -- you might want to ask
> around on the #hurd IRC channel on for help if you
> don't get an answer here.
> Derek
> Ognyan Kulev <> writes:
> > Dmitry V. Zhulanov wrote:
> > 
> > > And the problem appears after reboot my box:
> > > after typing login root and password, hurd prints "Authentication 
> > > failure: (ipc/mig) server died". Others hard rebuts, fsck, login root 
> > > leads to same result.
> > > 
> > > How can i fix this?
> > 
> > This was discussed in February, but there was no conclusion.  The auth 
> > server seems to crash.  Type "su -" in the "login> " prompt.
> > 
> > Regards
> > -- 
> > Ognyan Kulev <>, "\"Programmer\""
> > 
> > 
> > 
> > _______________________________________________
> > Help-hurd mailing list
> >
> >
> _______________________________________________
> Help-hurd mailing list
Joachim Nilsson :: <joachim AT vmlinux DOT org> 
+46(0)21-123348 :: <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]