[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

settrans problems

From: David Allen
Subject: settrans problems
Date: Sun, 27 May 2001 02:18:26 -0400
User-agent: Mutt/1.2.5i

I just installed the hurd, by grabbing gnu-latest.tar.gz, etc.
Running native-install twice worked just fine, and now the system is
up and running.

But when I try to set up my cdrom drive, "settrans -c /cdrom
/hurd/isofs /dev/hd1" and then try to list the contents, I get
"/cdrom: permission denied". I can't even list the file attributes.
showtrans seems to say that everything is set up just fine.  I
recently ran MAKEDEV hd1 for the cdrom drive and showdev seems to
think everything is fine there too.

Additionally, when I use the -a flag, as in "settrans -ca /cdrom
/hurd/isofs /dev/hd1" then I get the same permission denied error,
only it's permission denied on /hurd/isofs (which I also can't list
attributes on of course)  The permission denied on /hurd/isofs is
particular to when I use -a.  Of course out of ignorance I've tried
chmod'ing both /cdrom and/or /hurd/isofs to 755, but that doesn't work
either with permission denied.  What's going on?

Also, I'm having problems with the network translator.  I run settrans
/servers/socket/2 -fg /hurd/pfinet --interface=eth0 --address=
--gateway= --netmask=  My GNU/Linux machine
is the gateway.  When I try to ping the gateway, I get "ping: socket:
translator died".  Which of course doesn't mean much, since I get the
same message even when I haven't attempted to set up pfinet.

I've been scouring mailing lists for docs on these problems to no
avail.  I'm happy to RTFM if I can find it.  Any help would be
David Allen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]