[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-gsl] Cannot access GSL functions

From: Cactus
Subject: [Help-gsl] Cannot access GSL functions
Date: Tue, 30 Apr 2013 10:23:15 +0100

> Hello, Brian,
> I am really thankful for your answer. It is true that I am building GSL
with Visual Studio 2010. But actually my program worked one year ago when
someone else was using it. Also, fortran does not uses it. My fortran code
calls my c++ code, which is linked to gsl. I see it enters my c++ code and
it stops in the first gsl function. That is why I do not think there is a
problem with fortran. I do not understand either why he compiles well, he
finds the libraries, but he crashes after being turned into .exe.
> I tried what you suggested and the tests for gsl library succeeded very

> Just to be more specific, below I show you the steps I am following to
install the library GSL 1.8 and link it to my Visual Studio 2010. Is any
step missing? Do you think it would be better to use a more recent version
of gsl? If yes, where I can find it and what manual to link it to Visual
Studio 2010 can I use?
I am not sure that it will help but you might try a more recent version
of the library.  My Visual Studio 2010 build is available here:

If this doesn't help, perhaps you can write a simple example that fails,
which I can take a look at.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]