[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-GIFT] is it possible to compile GIFT in Cygwin?

From: Alexis H. Rivera-Rios
Subject: Re: [help-GIFT] is it possible to compile GIFT in Cygwin?
Date: Wed, 16 Apr 2003 13:31:54 -0700 (PDT)

Hi Wolfgang,

I'm also sending a copy of this email to the mailing
list.  Should I do this or just reply to you?

The version of Cygwin that I download is 1.3.22-1

I found some documentation on the distribution.  It
stated the prerequisitites before building.  

Currently, I have Perl 5.8.0 installed.  I noticed the
documentation stated that it requires a perl younger
than 5.003.  I went to the cpan site, I found some
other distributions but I don't know which one to
download. I saw a 4.036, 5.005 03, 5.004 05.. etc
Is it very important to have the specific perl

Not knowing that, I assumed that 5.8 was ok so I
downloaded the perl modules.  One of them (libwww)
didnt pass the make test, I dont know if this is a
problem with perl 5.8 or it needs some other libraries
from Cygwin that I havent downloaded.  I noticed in
the history of the libwww module that they made a
change to  the code so it compiles with 5.8, I guess
they haven't fixed that yet :)
The make test of some other modules said that some
tests were skipped, I dont know if that is good or

I also downloaded the binaries of the infomagick
ibary.  I don't if I have to the its location to the

I installed doxygen but I dont know how to verify it's
working correctly. I've never used that before.

Do I need to have some sort of networking support in
Cywgin?  Maybe I didnt installed some base networking
libraries, that we are assuming are there always.

Having said that, here is the errors log when I try to
build gift.

mkdir: cannot create directory `autoDoc': File exists
make[2]: [system-doc] Error 1 (ignored)
mkdir: cannot create directory `autoDoc/HTML': File
make[2]: [system-doc] Error 1 (ignored)
make[2]: [system-doc] Error 1 (ignored)
make[2]: [] Error
1 (ignored)
make[2]: [configuring-and-hacking-the-gift.txt] Error
1 (ignored)
make[2]: [configuring-and-hacking-the-gift.dvi] Error
1 (ignored)
make[2]: [gift-guide.dvi] Error 1 (ignored)
test: gift-guide.sgml: unknown operand
make[2]: [gift-guide.txt] Error 2 (ignored)
make[2]: [] Error 1 (ignored)
cannot find -ldl
collect2: ld returned 1 exit status
make[3]: *** [gennmtab.exe] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive-am] Error 2

Any comments, ideas or suggestions?


--- Wolfgang Müller
<address@hidden> wrote:
> > I'm trying to compile GIFT in Cygwin, but so far I
> > have not being succesful.  I tried v0.1.9 but the
> .gz
> > file that I downloaded was corrupted
> > (  
> What? Can anyone confirm this?
> > I tried v0.1.8 but I
> > got compilation errors.  
> If you gave me the compilation errors, this would be
> great. Which version of 
> cygwin did you use?
> > I didn't see any FAQs or any
> > documentation saying on what platforms it has been
> > succesfully compiled, although I know it works in
> > Linux.  Again, maybe I'm not looking in the right
> > place :)
> Oh, there is something quite specific in the
> Documentation of the tar you did 
> not manage to unpack. Currently, it should compile
> under GNU/Linux. There are 
> a couple of reasons why compiling GIFT might fail
> under Cygwin, especially 
> the plugin mechanism comes to mind. There it would
> be good to make it more 
> libtool compatible. Currently, I use libtool in some
> places, in some other 
> ones I do not do everything libtool would allow. 
> If you have the power and the interest to do some
> work on this, I (and I guess 
> the others, too) would be happy to coach you on
> this.
> > I will appreciate any comments or suggestions.
> Don't hesitate to ask more questions.
> Cheers,
> Wolfgang

"Nunca pienses en la suerte, 
  porque la suerte es: el pretexto de los fracasados"
Pablo Neruda

Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]