[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Fwd: Can not install slime for emacs on my windows-7-64

From: Rob Davenport
Subject: Re: [h-e-w] Fwd: Can not install slime for emacs on my windows-7-64
Date: Wed, 3 Dec 2014 14:04:59 +0000

If you started emacs with –Q, it shouldn’t be using your .emacs, correct?  That would seem to indicate it’s not a problem with your .emacs.  Would think it’s a difference in your emacs installations or environment.  What differences between the working and non-working emacs machines can you think of?  (other than Win7 vs. Win 8). 


I’m not familiar with slime, but from the traceback you show it looks like the problem is with url-retrieve (in url.el).   (Are you behind a firewall?  On one system but not the working one maybe?)

When I try that command (without slime) I get:

(url-retrieve "" 'print)

#<buffer  *http*>

And ‘nil’ in the message window.  I’m not sure if that’s a good test or test result though.


Have you tried ‘eww’ or other emacs web browser?  With eww I can get to that url ok (and have my proxy set up to get through firewall).


Can you tell how many open files there are when you run that command (before/during/after ideally)?  SysInternals’ ProcessExplorer might help, but a command-line tool would be better.  Is there some way to increase the maximum number of open files allowed?  I just remember something for that from the old DOS days but maybe there’s a Windows registry setting that would help.  Like ulimit but for Windows.  One site indicates max is 2048 and no mentioned way of increasing it.   (


This page ( suggests a similar problem was due to insufficient timeout value when creating an external process from Emacs on Windows, but it looks like that may be specific to the EPC package for Emacs or emacs-jedi.  Perhaps it could be related.


Can you run other commands in Emacs that launch external processes?   What other commands might make use of url-retrieve or make-network-process, or open-network-stream?


I see you’ve asked this question in a lot of places online.  If you find an answer, I hope you add the resolution to them for others’ benefits. J





From: help-emacs-windows-bounces+address@hidden [mailto:help-emacs-windows-bounces+address@hidden On Behalf Of ye eugene
Sent: Wednesday, December 03, 2014 4:40 AM
To: Eli Zaretskii
Cc: address@hidden
Subject: Re: [h-e-w] Fwd: Can not install slime for emacs on my windows-7-64


Well,there must be something wrong with my windows-7-64.Because this worked on my another computer(windows 8).For some reason,I do not want to change my system.So I hope someone can find out what is wrong with my windows or emacs.


2014-12-02 22:27 GMT+08:00 Eli Zaretskii <address@hidden>:

> Date: Mon, 1 Dec 2014 11:09:30 +0800
> From: ye eugene <address@hidden>
> After I start emacs by "emacs -Q",then type (url-retrieve ""
> 'print).It shows the error:
> Debugger entered--Lisp error: (file-error "make client process failed" "too
> many open files" :name "" :buffer #<buffer *url-http-temp*> :host
> "" :service 80 :nowait nil)
> make-network-process(:name "" :buffer #<buffer *url-http-temp*> :host
> "" :service 80 :nowait nil)
> open-network-stream("" #<buffer *url-http-temp*> "" 80 :
> type plain :nowait nil)
> byte-code("\306\211 \n\307>\203$

I cannot reproduce this.  Do I need to install SLIME for the error to
happen?  If so, where do I download it?

Also, which version of Emacs did you use?  I tried 24.4 and the
current development master branch, and they both worked.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]