[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[h-e-w] Fwd: Can not install slime for emacs on my windows-7-64

From: ye eugene
Subject: [h-e-w] Fwd: Can not install slime for emacs on my windows-7-64
Date: Mon, 1 Dec 2014 11:09:30 +0800

After I start emacs by "emacs -Q",then type  (url-retrieve "" 'print).It shows the error:
Debugger entered--Lisp error: (file-error "make client process failed" "too many open files" :name "" :buffer #<buffer  *url-http-temp*> :host "" :service 80 :nowait nil)
  make-network-process(:name "" :buffer #<buffer  *url-http-temp*> :host "" :service 80 :nowait nil)
  open-network-stream("" #<buffer  *url-http-temp*> "" 80 :type plain :nowait nil)
  byte-code("\306\211 \n\307>\203$

2014-11-28 23:02 GMT+08:00 Eli Zaretskii <address@hidden>:
> Date: Fri, 28 Nov 2014 16:50:50 +0800
> From: ye eugene <address@hidden>
> I download lispbox ( ) lispstick
> ( ) .When i run them on my windows 7-64,they
> all shows the same error:
> Debugger entered: (("Error in timer" slime-attempt-connection (#<process
> inferior-lisp> nil 5) (file-error "make client process failed" "too many open
> files" :name "SLIME Lisp" :buffer nil :host "" :service 33947 :nowait
> nil)))
> (condition-case data (apply fun args) ((debug error) (debug nil (list "Error in
> timer" fun args data))))
> slime-timer-call(slime-attempt-connection #<process inferior-lisp> nil 5)
> apply(slime-timer-call (slime-attempt-connection #<process inferior-lisp> nil
> 5))
> byte-code("r\301 \302H \303H\"\210)\301\207" [timer apply 5 6] 4)
> timer-event-handler([t 21620 23714 532000 nil slime-timer-call
> (slime-attempt-connection #<process inferior-lisp> nil 5) nil 0])
> When I try to add (url-retrieve "" 'print) to .emacs and then
> run emacs,it shows the error:
> Warning (initialization): An error occurred while loading `f:/lisp/.emacs':
> File error: make client process failed, too many open files, :name,,
> :buffer, #, :host,, :service, 80, :nowait, nil
> I asked the author of slime,he said it is not a slime bug.So I want to know
> what's the error and how to fix it.

Please start by describing how to reproduce the problem starting from
"emacs -Q".

reply via email to

[Prev in Thread] Current Thread [Next in Thread]