[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[h-e-w] Windows 7, `w32-register-hot-key' has no effect?

From: Drew Adams
Subject: [h-e-w] Windows 7, `w32-register-hot-key' has no effect?
Date: Tue, 4 Jun 2013 08:21:04 -0700 (PDT)

Anyone clue about this?

1. I use this, which has always worked before (e.g., in Windows XP):

(w32-register-hot-key [M-tab])
(w32-register-hot-key [M-S-tab])

That no longer seems to have any effect.  `M-TAB' in Emacs now just
does its default MS Windows thing.

2. I have another program that assigns `C-mouse-3' as a hot key.
(I can disable that, but I would like to understand.)

That has the effect that Emacs never sees `C-mouse-3' at all (whether
or not I bind it to a key in Emacs).  (But if I disable the other
program's hot-key definition, no problem: Emacs sees it OK.)

I tried this, but it apparently has no effect here either:
(w32-register-hot-key [C-mouse-3])
(w32-register-hot-key [C-down-mouse-3])

IOW, if another program defines C-mouse-3 as a hot key, there seems
to be no way for Emacs to get it back, for use inside Emacs.

Anyone know a workaround?  Am I missing something obvious?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]