[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Plot in Octave under Gnu Emacs on Windows XP doesn't work

From: Lars Ericson
Subject: Re: [h-e-w] Plot in Octave under Gnu Emacs on Windows XP doesn't work
Date: Mon, 22 Oct 2012 13:43:09 +0000 (UTC)
User-agent: Loom/3.14 (

Eli Zaretskii <eliz <at>> writes:

> > From: Lars Ericson <lars.ericson <at>>
> > Date: Fri, 19 Oct 2012 19:51:22 +0000 (UTC)
> > 
> > In Octave outside of Emacs I run the octave command "plot(1:10)" and it 
> > up a qt window and plots.  Inside Gnu Emacs I run command esc-X run-octave 
> > that runs an inferior mode Octave window which calls the same Octave.exe 
> > program.  Inside that I do "plot(1:10)" and no Qt window pops up.  I have 
> > tried the Octave command "graphics_toolkit gnuplot;" followed by "plot
> > inside the Octave window, and that doesn't help.
> Does Octave need to see that its input is coming from a console, to be
> able to pop up the window and plot?  If so, that's the reason: on
> Windows, Emacs subprocesses are run through a pipe, not a pty as on
> Unix.
> If that's not the reason, then I suggest to ask on some Octave-related
> forum, or maybe look in some FAQ, what could be the reason(s) for not
> popping up that window.  If you then describe those reasons here,
> maybe someone could figure out why it happens in run-octave, and what,
> if anything, can be done to work around that.
> > This was suggested in the following stackoverflow thread for Windows
> > 7 (I am on XP):
> >
> > support-in-emacs
> That thread says that gnuplot doesn't work in Calc, which is wrong
> since Aug 2009.  Perhaps the person who said that uses an old Emacs
> version.

The pipes idea is confirmed by Michael Goffioul on address@hidden  He says:

Yes, that's most probably the problem. FLTK and Qt backend uses the readline 
event loop to run events and/or interact with the graphics backend. If 
readline is not used, like when running octave over pipes, those graphics 
backend won't work. You may force readline usage with the flags: --line-
editing -i

reply via email to

[Prev in Thread] Current Thread [Next in Thread]