[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Plot in Octave under Gnu Emacs on Windows XP doesn't work

From: Eli Zaretskii
Subject: Re: [h-e-w] Plot in Octave under Gnu Emacs on Windows XP doesn't work
Date: Sat, 20 Oct 2012 00:31:48 +0200

> From: Lars Ericson <address@hidden>
> Date: Fri, 19 Oct 2012 19:51:22 +0000 (UTC)
> In Octave outside of Emacs I run the octave command "plot(1:10)" and it pops 
> up a qt window and plots.  Inside Gnu Emacs I run command esc-X run-octave 
> and 
> that runs an inferior mode Octave window which calls the same Octave.exe 
> program.  Inside that I do "plot(1:10)" and no Qt window pops up.  I have 
> tried the Octave command "graphics_toolkit gnuplot;" followed by "plot(1:10)" 
> inside the Octave window, and that doesn't help.

Does Octave need to see that its input is coming from a console, to be
able to pop up the window and plot?  If so, that's the reason: on
Windows, Emacs subprocesses are run through a pipe, not a pty as on

If that's not the reason, then I suggest to ask on some Octave-related
forum, or maybe look in some FAQ, what could be the reason(s) for not
popping up that window.  If you then describe those reasons here,
maybe someone could figure out why it happens in run-octave, and what,
if anything, can be done to work around that.

> This was suggested in the following stackoverflow thread for Windows
> 7 (I am on XP):
> support-in-emacs

That thread says that gnuplot doesn't work in Calc, which is wrong
since Aug 2009.  Perhaps the person who said that uses an old Emacs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]