[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [h-e-w] problems with RCS rcsdiff and checkout co.exe in emacs 22.3.

From: Tolkin, Steve
Subject: RE: [h-e-w] problems with RCS rcsdiff and checkout co.exe in emacs 22.3.1
Date: Fri, 14 Nov 2008 14:09:39 -0500

Thanks to Eli's suggestion I have more useful information about the
problem, but I still have not solved it.
It does not occur when I use the runemacs.exe program from a DOS box.
For example this works correctly: 
  cd c:\emacs\bin

I discovered this by first doing runemacs -Q , then runemacs -q , then
just runemacs .  Also, if after runemacs -q or -Q I run my emacs init
file it still works correctly. (Note its name starts with an underscore
not a dot as is usual)
  load-file ~/_emacs.elc 

The problem only occurs when I start emacs using the mouse: Start |
Programs | Gnu Emacs | Emacs
The Properties for the last node above says in part:
Which is the right place.

One possible cause of the problem is that I first unzipped the
installation into c:\emacs-22.3
and then ran the addpm.exe program in bin.  When I decided things were
working OK I renamed the top directory to c:\emacs and then run addpm
I suspect something bad happened as a result of this.  I think this
should have worked, based on the install documentation at which
also says there is no uninstall program.   (I think I want something
that will reverse the action of addpm .) 

I ran regedit and looked for the string "emacs" in all the places in the
registry but I did not notice anything suspicious, but I might have
missed something. 

Then I thought the problem might be caused by something in
C:\WINDOWS\Prefetch, but even after I deleted all 4 of these files the
problem occurred.

C:\WINDOWS\Prefetch>dir *emacs*
11/14/2008  01:11 PM            39,522
11/13/2008  01:03 PM            44,668
11/14/2008  01:11 PM             6,544
11/13/2008  01:03 PM             5,946

Eli also asked: But the files inside the RCS/ subdirectory do have the
,v suffix, right?

The files in my RCS directory do NOT end with ",v".   Is that a clue?  I
might have done something a long time ago to prevent that, but I cannot
find anyplace.   There is no environment variable that seems relevant
and I do not seem to have any files like rcs.ini or .rcs etc.  But maybe
there is some such configuration file.   Any ideas about that?


-----Original Message-----
From: address@hidden
[mailto:address@hidden On Behalf Of Eli
Sent: Friday, November 14, 2008 5:53 AM
To: Tolkin, Steve
Cc: address@hidden; address@hidden
Subject: Re: [h-e-w] problems with RCS rcsdiff and checkout co.exe
inemacs 22.3.1

> Date: Thu, 13 Nov 2008 17:26:13 -0500
> From: "Tolkin, Steve" <address@hidden>
> Cc: address@hidden
> In the new emacs 22.3.1 I have some problems with the RCS utilities.
> Below is the simplest example.   I also have a problem doing a checkin
> of an existing file after making an edit.  This problem is a
> "showstopper" for me using the new emacs.
> In emacs I create a new file named e.g. foo22, type "foo", and "C-x s"
> to save the file, and then "C-x v v" to checkin.
> That all works as expected.  The RCS/foo22 file is there and looks
> (See below.)
> Then I say "C-x v v" again to checkout, but it fails, with this
> vc-do-command: Running rcsdiff...FAILED (status 2)

I cannot reproduce this on my machine, using Emacs 22.3 invoked with
"emacs -Q".  If you use "emacs -Q", does the problem persist?

If "emacs -Q" doesn't work either, then please tell where did you get
the ported RCS package you are using.  Perhaps that port is somehow
subtly incompatible with how Emacs invokes subsidiary programs.  (I
needed to roll my own port of RCS because the one I downloaded from
GnuWin32 was buggy, and rcsdiff was indeed one of the problems.
However, in my case, it didn't work even from the command line.)

> I use an RCS directory (not the approach of having a ,v at the end of
> the file name.)

But the files inside the RCS/ subdirectory do have the ,v suffix,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]