[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Searching on Windows (find, grep, and indexed search)

From: Lennart Borgman (gmail)
Subject: Re: [h-e-w] Searching on Windows (find, grep, and indexed search)
Date: Sat, 29 Sep 2007 01:00:16 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20070728 Thunderbird/ Mnenhy/

Scott Jaderholm wrote:

Thanks for the reply

On 9/28/07, Lennart Borgman (gmail) <address@hidden> wrote:
Scott Jaderholm wrote:
1 - directory for file named "string"
Just to answer you I tried it (I am actually not using find-dired myself):

   M-x find-dired
   Run find in directory: YOUR-DIR
   Run find (with args): -name YOUR-FILE

It worked for me - so I learned something ;-)

I get this result:

  find . "(" -name test ")" -exec ls -ld "{}" ";"
  Access denied - .
  File not found - -NAME
  File not found - TEST
  find exited abnormally with code 1 at Fri Sep 28 15:44:36

This output is from the Windows find.exe program, not the gnuwin32 port of the unix find program.

So there must be some problem with the path. I wonder if I have made a mistake there. Could you please do

  F1 v
  Describe variable: w32shell-shell

and tell me the value of that variable?

I thought the default value was 'cmd but it seems to be nil. Can you set the value through Custom:

   M-x customize-variable

   Click on "Value Menu" and choose cmd.exe.
   Then either click on either "set for current session" or
   "save for future sessions".

Then true M-x find-dired again.

2 - directory for file containing "string"
Try lgrep or rgrep:

   M-x lgrep
   Search for (default "bla"): YOUR-STRING

That works for me, but I get the following error 16 times in
*Compile-Log* when I type M-x lgrepRET:
Warning: `error' called with 1 args to fill 0 format field(s)

Sorry, I do not understand. Please try to explain again.

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]