help-cgicc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: radio button lables?


From: Stephen F. Booth
Subject: RE: radio button lables?
Date: Fri, 4 May 2001 12:49:13 -0500

> So, you're thinking another if() check after the if(getType() ==
> eAtomic)?
> I'd like to get something in there, and if that's where you'd
> like to go with
> it, that'd be just fine - I'll do it if you'd like, or you can do
> it and I'll
> supply the patch to my devel. tree.

I was thinking of changing the implementation of render() in
HTMLElements.cpp.  The last code block currently looks like

  else {
    out << '<' << getName();
    if(getAttributes() != 0) {
      out << ' ';
      getAttributes()->render(out);
    }
    out << '>';

    if(getType() == eAtomic)
      return;

    <snip>
  }

I was thinking of changing it to

  else {
    out << '<' << getName();
    if(getAttributes() != 0) {
      out << ' ';
      getAttributes()->render(out);
    }
    out << '>';

    if(getType() == eAtomic) {
      if(getData().length() > 0)
        out << getData();
      return;
    }

    <snip>
  }

and also adding a method to GenericAtomicElement:

inline HTMLElement& text(const STDNS string& data) { setData(data); return
*this; }

Like I mentioned yesterday, I'm not sure about the name of the method.
text() is short and to the point, but I'm open to suggestions.  If you
wanted to just patch your sources, and send me a diff that would be great,
because I am in the process of changing the documentation from info to
doxygen which means I am monkeying with every header file.

-Stephen




reply via email to

[Prev in Thread] Current Thread [Next in Thread]