gzz-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gzz-commits] gzz/doc/pegboard/vob_bgvob--humppake peg.rst


From: Asko Soukka
Subject: [Gzz-commits] gzz/doc/pegboard/vob_bgvob--humppake peg.rst
Date: Thu, 06 Mar 2003 05:59:04 -0500

CVSROOT:        /cvsroot/gzz
Module name:    gzz
Changes by:     Asko Soukka <address@hidden>    03/03/06 05:59:03

Modified files:
        doc/pegboard/vob_bgvob--humppake: peg.rst 

Log message:
        back to current

CVSWeb URLs:
http://savannah.gnu.org/cgi-bin/viewcvs/gzz/gzz/doc/pegboard/vob_bgvob--humppake/peg.rst.diff?tr1=1.6&tr2=1.7&r1=text&r2=text

Patches:
Index: gzz/doc/pegboard/vob_bgvob--humppake/peg.rst
diff -u gzz/doc/pegboard/vob_bgvob--humppake/peg.rst:1.6 
gzz/doc/pegboard/vob_bgvob--humppake/peg.rst:1.7
--- gzz/doc/pegboard/vob_bgvob--humppake/peg.rst:1.6    Thu Mar  6 05:39:22 2003
+++ gzz/doc/pegboard/vob_bgvob--humppake/peg.rst        Thu Mar  6 05:59:03 2003
@@ -5,14 +5,14 @@
 :Authors:   Asko Soukka
 :Stakeholders: Benja Fallenstein, Tuomas Lukka 
 :Date-created: 2003-03-05
-:Last-Modified: $Date: 2003/03/06 10:39:22 $
-:Revision: $Revision: 1.6 $
-:Status:   Incomplete
+:Last-Modified: $Date: 2003/03/06 10:59:03 $
+:Revision: $Revision: 1.7 $
+:Status:   Current
 :Scope:    Trivial
 :Type:     Feature
 
 This PEG proposes creating **Abstract Background Vob** class, which
-implies creation of **Background Vob interface** and **Colored Vob
+implies creation of **Background interface** and **Colored
 Interface**.
 
 Background Vob is a very basic vob type, which enhances the Vob
@@ -24,32 +24,33 @@
    e.g. as parallel vertical stripes
 
 Background Vob implements interface for single color backround and
-border from Background Vob Interface and handling of multiple
-background colors from Colored Vob Interface.
+border from Background Interface and handling of multiple
+background colors from Colored Interface.
 
 Issues
 ------
 
 - How should the new interfaces and classes be named?
 
-  RESOLVED: **public interface BackgroundVob**, **public interface
-  ColoredVob** and **public abstract class AbstractBgVob**. In
+  RESOLVED: **public interface Background**, **public interface
+  Colored** and **public abstract class AbstractBgVob**. In
   AbstractBgVob the word Background is truncated after the current
-  *background vob* naming practice (SolidBgVob, RectBgVob, OvalBgVob).
+  *background vob* naming practice (``SolidBgVob``, ``RectBgVob``,
+  ``OvalBgVob``).
 
 - Where they should be located?
 
   RESOLVED: Currently in the package **``gzz.vob``**
-  (``gzz.vob.ColoredVob``, ``gzz.vob.BackgroundVob`` and
+  (``gzz.vob.Colored``, ``gzz.vob.Background`` and
   ``gzz.vob.AbstractBgVob``). Probably in the future they will be 
   moved into package ``org.libvob.vob``.
 
 - How should the common features of current background vobs be
-  splitted between Background Vob Interface and Colored Vob Interface?
+  splitted between Background Interface and Colored Interface?
 
   RESOLVED: Methods for single color backround and border will be
-  defined in Background Vob Interface and methods of multiple
-  background colors in Colored Vob Interface. The AbstractBgVob will
+  defined in Background Interface and methods of multiple
+  background colors in Colored Interface. The AbstractBgVob will
   contain the default implementations for them.
 
 - How should *solids* be renamed?
@@ -59,33 +60,33 @@
   should be called simply **colors**. Note that already the method
   adding them has been called *addColor*.
 
-- How should we store *colors*?
+- How should we store colors?
 
   RESOLVED: Since we are using the *java.util Collections API*
   the **ArrayList** implementation of List should be used.
 
-- What should be the default values for **bgcolor**, **drawBorder** and
+- What should be the default values for **bgColor**, **drawBorder** and
   **colors**?
 
-  RESOLVED: Default **bgColor** will be ``java.awt.Color.white``,
-  **drawborder** will be **true** and **colors** will be **null**.
+  RESOLVED: Default bgColor will be **``java.awt.Color.white``**,
+  drawborder will be **true** and colors will be **null**.
   These are the currently used default settings for background vobs.
  
 Changes
 -------
 
-The Java classes **public interface BackgroundVob**, **public interface
-ColoredVob** and **public abstract class AbstractBgVob** should  be
+The Java classes **public interface Background**, **public interface
+Colored** and **public abstract class AbstractBgVob** should  be
 created after the following diagram:
 
 .. UML:: backgroundvob
 
     jlinkpackage gzz.vob
 
-    class Vob
+    class Vob "abstract"
         jlink
 
-    class BackgroundVob Interface
+    class Background "interface"
         methods
            +void setBgColor(Color c)
            +Color getBgColor()
@@ -94,14 +95,14 @@
            +void setDrawBorder(Boolean b)
             +Boolean getDrawBorder()
    
-    class ColoredVob Interface
+    class Colored "interface"
         methods
            +void addColor(Color c)
            +List getColors()
 
-    class AbstractBgVob Abstract
-        realize ColoredVob
-        realize BackgroundVob
+    class AbstractBgVob "abstract"
+        realize Colored
+        realize Background
         inherit Vob
         methods
            #Boolean drawBorder
@@ -124,25 +125,26 @@
         inherit vobs.ColoredSectorVob
 
    ---
-   horizontally(50, vob_h, ColoredVob, Vob, BackgroundVob);
+   horizontally(50, vob_h, Colored, Vob, Background);
    vertically(50, vob_v, Vob, AbstractBgVob, vobs.RectBgVob);
    horizontally(50, vobs_h, vobs.SolidBgVob, vobs.RectBgVob, vobs.OvalBgVob);
    vertically(50, sector_v, vobs.SolidBgVob, vobs.ColoredSectorVob);
    horizontally(50, sector_h, vobs.ColoredSectorVob, 
vobs.ColoredSquareSectorVob);
 
-The following background vobs should be modified to inherit AbstractBgVob:
+The following background vobs should be modified to inherit
+``AbstractBgVob``:
 
- - gzz.vob.vobs.RectBgVob
- - gzz.vob.vobs.SolidBgVob
- - gzz.vob.vobs.BgVob
-
-Also **ColoredSectorVob** should be inherited from AbstractBgVob:
-
-Some of the current vobs should be changed to implement this interface
-(``RectBgVob`` and ``ColoredSectorVob``). Also some other Vobs should
-be changed to use a new *color* Vector instead of old *nsolids* color
-counter and *solids* Color array. No ``CellViews`` or ``NodeViews``
-should be broken after this change, since RectBgVob's addColor
-interface remains same. Although, at least Loom's ``NodeViews`` should
-be build using ``BgVob`` instead of ``RectBgVob`` or any other particular
-Vob.
+ - ``gzz.vob.vobs.RectBgVob``
+ - ``gzz.vob.vobs.SolidBgVob``
+ - ``gzz.vob.vobs.BgVob``
+
+Also ``gzz.vob.vobs.ColoredSectorVob`` should be inherited from
+AbstractBgVob. Semantically *colored sector vobs* are not meant to be
+background vobs, but they do have the same features. The difference to
+background vobs will be done by dropping ``Bg`` off from their naming.
+
+No **Cell Views** or **Node Views** should be broken after this
+change, since background vobs' addColor interface remains
+same. Although, at least Loom's Node Views should be build using
+Abstract Background Vob instead of ``RectBgVob`` or any other
+particular Vob.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]