guile-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] GC code cleanup


From: Han-Wen Nienhuys
Subject: Re: [PATCH] GC code cleanup
Date: Fri, 23 Dec 2005 11:23:01 +0000 (UTC)

In article <address@hidden>,
Ludovic Courtès <address@hidden> wrote:
>Hi,
>
>The patch below is an attempt to clean up the GC by limiting the use of
>global variables for statistics.  IMO it makes it easier to read the
>code.  Furthermore, it's also easier to track the exact number of cells
>swept/collected at each stage.
>

thanks for your patch!

> void
>-scm_i_adjust_min_yield (scm_t_cell_type_statistics *freelist)
>+scm_i_adjust_min_yield (scm_t_cell_type_statistics *freelist,
>+                      unsigned cells_collected,
>+                      unsigned cells_swept)

you're passing this as a combination everywhere. I think it would be
cleaner to create a

  scm_t_sweep_statistics

containing these numbers. Also, you're passing these vars along mostly
with with a scm_t_sweep_statistics ptr. Isn't it better to add the
collected/swept numbers to that structure?

d





reply via email to

[Prev in Thread] Current Thread [Next in Thread]