guile-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: snarfer guard macro name decision: SCM_MAGIC_SNARFER


From: Marius Vollmer
Subject: Re: snarfer guard macro name decision: SCM_MAGIC_SNARFER
Date: 14 Mar 2002 19:48:55 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1

Thien-Thi Nguyen <address@hidden> writes:

> old_school_snarf ()
> {
> sed -e 's/SCM_CONST_LONG/SCM_GLOBAL_VCELL_INIT/g' \
>     -e 's/SCM_GLOBAL_VCELL_INIT/SCM_GLOBAL_VARIABLE_INIT/g' \
>     -e 's/SCM_GLOBAL_VCELL/SCM_GLOBAL_VARIABLE/g' \
>     -e 's/SCM_VCELL_INIT/SCM_VARIABLE_INIT/g' \
>     -e 's/SCM_VCELL/SCM_VARIABLE/g' \
>     $1 > ${temp}
> cp ${temp} $1
> modern_snarf "$@"
> }

Don't do this.  First, SCM_VCELL and SCM_VARIABLE are not the same
thing.  You can't substitute one for the other.  (Likewise for the
substitutions.)  Second, we already keep proper backward compatibility
in the C code itself:

    #if (SCM_DEBUG_DEPRECATED == 0)

    #define SCM_CONST_LONG(c_name, scheme_name,value) \
    SCM_VCELL_INIT(c_name, scheme_name, scm_long2num(value))

etc...



reply via email to

[Prev in Thread] Current Thread [Next in Thread]