grub-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] a.out kernel loader


From: Robert Millan
Subject: Re: [PATCH] a.out kernel loader
Date: Sun, 27 Jan 2008 20:41:35 +0100
User-agent: Mutt/1.5.13 (2006-08-11)

On Mon, Jan 28, 2008 at 02:53:14AM +0800, Bean wrote:
> Hi,
> 
> This patch add support for a.out kernel, which includes the 4th loader
> of BSD system. For example, to start FreeBSD:

Cool!

How FreeBSD-specific is this?  Will the same module apply to other a.out
binaries ?  (I ask since you gave it a generic name)

> +++ b/loader/i386/pc/aout.c

How i386-specific is it?  Can it possibly work for non-i386 objects in the
future?

> +/* a_mid */
> +#define      MID_ZERO        0       /* unknown - implementation dependent */
> +#define      MID_SUN010      1       /* sun 68010/68020 binary */
> +#define      MID_SUN020      2       /* sun 68020-only binary */
> +#define MID_I386     134     /* i386 BSD binary */
> +#define MID_SPARC    138     /* sparc */
> +#define      MID_HP200       200     /* hp200 (68010) BSD binary */
> +#define      MID_HP300       300     /* hp300 (68020+68881) BSD binary */
> +#define      MID_HPUX        0x20C   /* hp200/300 HP-UX binary */
> +#define      MID_HPUX800     0x20B   /* hp800 HP-UX binary */

These aren't used through the code.  Did you copy them from a standard
header or so?

> +static grub_err_t
> +grub_aout_boot (void)
> +{
> +  grub_multiboot_real_boot (entry, 0);

Ugh :-)

Is there really anything desired from grub_multiboot_real_boot?  (other than
grub_dl_unload_all and grub_stop_floppy)

I wonder if it makes sense to split grub_dl_unload_all/grub_stop_floppy out
of grub_multiboot_real_boot to make a generic "real_boot" function that
lives in kernel and is used by grub_multiboot_real_boot and directly by
modules like this one.

-- 
Robert Millan

<GPLv2> I know my rights; I want my phone call!
<DRM> What use is a phone call… if you are unable to speak?
(as seen on /.)




reply via email to

[Prev in Thread] Current Thread [Next in Thread]