[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 on a Macbook.

From: Marco Gerards
Subject: Re: Grub2 on a Macbook.
Date: Sat, 10 Nov 2007 18:09:05 +0100
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/21.4 (gnu/linux)

Isaac Dupree <address@hidden> writes:

> Eoin Hennessy wrote:
>> Hello all,
>> I've been taking a look at grub2 on an EFI Apple Macbook. I've
>> installed a build from CVS HEAD and I can chainload grub.efi via the
>> rEFIt loader. When grub loads I'm seeing the 'grub rescue>' command
>> prompt. As a test, I'd like to chainload OSX's boot.efi using the
>> 'chainloader' command listed at [0] but the command is reported as
>> 'unknown'. I've also tried the instructions at [1] but it allooks like
>> grub.cfg is being ignored. Perhaps someone could point me in the right
>> direction.
> In May/June 2007 I failed at using Grub2 cvs - efi on my new MacBook
> too, with the same issue.  But I'm using Grub2 with legacy boot
> sequence to boot... because it understands GPT :)  and that works
> except the keyboard usually doesn't work during boot because of
> Apple's buggy bios.

Are you aware of other bootloaders that do *not* have this problem?  I
experienced this with GRUB Legacy.  The workaround was not pretty...

> I'm not sure if chainloading would work due to grub2 not understanding
> HFS+ ?  I tried putting grub2-efi and a linux kernel image on a
> FAT16/vfat partition.

It *does* understand HFS+, if you load the hfsplus.mod module :-)

> Anyway I can probably help test anything if needed.

Can you please send in bug reports whenever something in GRUB 2
doesn't work?  Or better: document it on the wiki so we will not
forget about this :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]