[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

a FAQ that probably isn't that trivial to answer ...

From: Udo Rader
Subject: a FAQ that probably isn't that trivial to answer ...
Date: Tue, 02 Oct 2007 01:03:22 +0200


for various reasons I decided to give grub2 a try and now I am caught in
the "my system doesn't boot" trap.

The problem is probably a bit more complex then it seems at first hand,
because my system doesn't even start into grub at all but "freezes"
somewhere between hard disk detection and starting up grub. Absolutely
no message is displayed after the POST is complete.

The only chance I can currently somewhat revive my system is by
unplugging the hard drive before powering up the system, inserting some
kind of boot CD (in my case a debian etch installation CD), plug in the
hard drive and then boot into rescue mode.

In rescue mode I see the the hard drive itself (and the data on it) is
completely OK and so after many hours of trying I am completely lost ...

Things were working absolutely OK before I tried to install grub2. Yet
now, reinstalling whatever bootloader does not bring my system back into
normal booting again. So far I have tried to reinstall grub legacy and
even lilo, but all without success.

grub-install/update-grub gives this:

% grub-install --recheck /dev/sda
Installation finished. No error reported.
This is the contents of the device map /boot/grub/
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(hd0)   /dev/sda
% update-grub
Searching for GRUB installation directory ... found: /boot/grub
Testing for an existing GRUB grub.cfg file ...
found: /boot/grub/grub.cfg
Searching for splash image ... found: /boot/grub/splash.xpm.gz
Found kernel: /vmlinuz-2.6.22-12-generic
Found kernel: /memtest86+.bin
Updating /boot/grub/grub.cfg ... done

The hints on also did not bring me
anywhere, so any ideas are greatly appreciated ...

If my box hadn't worked without problems before, I would consider a
firmware issue, but I can hardly believe that to be the case ...

Udo Rader EDV Systemhaus GmbH

Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]