On Sun, 3 Aug 2003, SP LEE wrote:
> Arend,
>
> I will move the code I added to the new function
find_more_semeai_moves(). I
> would think the semeai module should add type information to the
generated
> move, such as disconnect move, nakade move, etc. It's more efficient
than
> analyze it afterward.
Sorry, you probably misunderstood me. What I meant is that such a function
find_more_semeai_moves() should work analogously to the other
find_more_...() functions we have in value_moves.c: I.e. candidate moves
are selected, and then the function owl_analyze_semeai_after_move()
should be called to check whether these moves win the semeai, too.
Where you put such a code is not that important. However, the advantage
of putting it in value_moves.c is that you will only do these additional
calls to owl_analyze_semeai_after_move() (which are expensive, of
course) for the color that will move next, i.e. you will save the checks
for the other color that will have no effect.
I really think it is too dangerous to just assume that these moves work,
without checking them.
Arend