[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnucap-devel] CMake

From: Guilherme Brondani Torri
Subject: Re: [Gnucap-devel] CMake
Date: Fri, 10 Feb 2017 21:26:31 +0100


It was nice meeting Al and Felix at FOSDEM 2017.
Allow me to restart this thread about 2 years after it first started.

I just managed to rebuild gnucap on my Mac.
Please have a look in the branch update_cmake_osx_build [1].
I merged the latest autotools branch on my modified version of cmake
So, it now contains gnucap and CMake fixes.
It is running well. A few tests are failing. I will try to find out more
about them later.

I also had to create a /usr/local/bin/gnucap.rc containing:
"load /usr/local/lib/gnucap/gnucap-default-plugins.dylib"

For some reason it would not find the plugins:
main version: unstable 2016.11.17
core-lib version: unstable 2016.11.17
load gnucap-default-plugins.dylib
     ^ ? dlopen(gnucap-default-plugins.dylib, 6): image not found
libc++abi.dylib: terminating with uncaught exception of type Exception_CS
Abort trap: 6

So, CMake is working for me.

So far I haven't tried the Make1, Make2, Make3 makefiles.

I also tried fixing the autotools build, see [2] (which is now based on
It builds fine but I am unable to run it. See bellow:

>From the build directory:
[autotools-osx]~/git/gnucap $ ./main/gnucap
./main/gnucap.real: line 117:
/Users/guitorri/git/gnucap/main/.libs/gnucap.real: cannot execute binary
./main/gnucap.real: line 117:
/Users/guitorri/git/gnucap/main/.libs/gnucap.real: Undefined error: 0

After make install:
[autotools-osx]~/git/gnucap $ gnucap
-bash: /usr/local/bin/gnucap: cannot execute binary file
[autotools-osx]~/git/gnucap $ which gnucap
[autotools-osx]~/git/gnucap $ otool -L /usr/local/bin/gnucap
.libs/gnucap.real (compatibility version 0.0.0, current version 0.0.0)
/usr/local/lib/libgnucap.0.dylib (compatibility version 1.0.0, current
version 1.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version
/usr/lib/libedit.3.dylib (compatibility version 2.0.0, current version
/usr/lib/libncurses.5.4.dylib (compatibility version 5.4.0, current version
/usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version

How to proceed to get the functioning patches upstream?
Shall I split the patches targeting unstable, cmake and autotools branches?

Best regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]