[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] gNewSense 3 installed fine on Yeeloong

From: Michał Masłowski
Subject: Re: [gNewSense-users] gNewSense 3 installed fine on Yeeloong
Date: Thu, 04 Oct 2012 20:18:26 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2 (gnu/linux)

> 10. Later it warns you that no boot loader was installed.
> No boot loader installed
> You will need to boot manually with the /vmlinux kernel
> and partition /dev/mapper/****-root
> passed as a kernel argument.
> ** Important to remember this message **

It is/will be possible to install grub instead, although it also needs
some configuration (and IMO isn't much needed).

> PMON> g console=tty no_auto_cmd machtype=8.9 root=/dev/****-root

I use more options with Parabola:

resume=/dev/sda3 libata.force=80c

the first one should point to the swap partition and is needed for
hibernation, the second one makes the disk faster (although still slow).

> 13. My machine started but I didn't get a Graphical interface.
> What happened to me was this. The machine started booting up, then 
> there was a flashing cursor in the top left of the screen.
> I pressed F4 and got a login prompt. Logged in, then as superuser i
> removed the siliconmotion driver.
> apt-get remove xserver-xorg-video-siliconmotion

There are various patches for the driver and the X server that solve
this.  Maybe gNewSense 3.0 will have an old enough X server for this
driver to be faster.

> 1. Boot
> I will make it boot directly from PMON. I think I can do this by
> setting the al and karg variables.
> I have already tried setting the variables at the PMON prompt like this:
> PMON> set al (wd0,0)/vmlinux-3.5.3-gnu

Or have the /boot/boot.cfg (or /boot.cfg) file on the first partition,
with content like this:

title gNewSense
kernel (wd0,0)/vmlinux-3.5.3-gnu
args console=tty no_auto_cmd machtype=8.9 root=/dev/****-root

(If you have a vmlinuz-* file, it will be faster to boot.)

> 2. External monitor
> It works with an external monitor although its a bit blurry. What can
> I do? Do I need to change the resolution?

There is a kernel option for that, I never used it.  If
xserver-xorg-video-siliconmotion worked, it would support changing it in
/etc/X11/xorg.conf, there are patches for older versions that might
support using xrandr or graphical tools for that.

The external display quality is lower than from my other computers even
with the correct resolution.

Attachment: pgpCIgc6O8hUY.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]