[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gNewSense-users] gNewSense 3 installed fine on Yeeloong

From: t s
Subject: [gNewSense-users] gNewSense 3 installed fine on Yeeloong
Date: Thu, 4 Oct 2012 19:07:03 +0100 (BST)

Good news. I got gNewSense3 running on my Lemote Yeeloong 8089_b 8.9. Thankyou 
gNewSense team, contributors and FSF.

If you are trying to install gNewSense 3 on a Yeeloong laptop you can see how I 
did it below.

It took me a few attempts. I tried different disk partitioning schemes, in the 
end I did a guided partition with /home in its own partition plus LVM.

This is what I did...

1. Download the necessary files and put them on a memory stick which was 
formatted to ext3.

You need these files:

2. Put memory stick into the Yeeloong, then switch it on. When the logo appears 
press Del lots of times until the PMON prompt comes up.

3. When the PMON prompt appears do this:
PMON> load (usb0,0)/vmlinux-3.5.3-gnu
PMON> initrd (usb0,0)/initrd.gz
PMON> g console=tty no_auto_cmd

If you can't run the commands above you can try the dir command like this:
PMON> dir (usb0,0)/
this lets you see whats on the disk, it can also be helpful when you are trying 
to boot your machine.

4. Install process starts.
Select language, country, keyboard setup.

5. Install process continues.
The install process asks you for: admin password, machine name, domain, 
username and password.

** IMPORTANT to remember  these **
This is used to boot up later on.

6. Partition the disk
I chose Guided Partition.
Then I chose Seperate /home partition with LVM
I chose MSDOS partitions (it worked for me).

7. The install process later asks you to select the kernel.

You will see linux-image-3.5.3-gnu-loongson-2f. Select it.

8. Repository Warning
Later on you will see a warning saying Cannot access repository

The file /etc/apt/sources.list is affected by this stage but for now just 

9. Select what to install.
choose Graphical Desktop Environment.

10. Later it warns you that no boot loader was installed.

No boot loader installed
You will need to boot manually with the /vmlinux kernel
and partition /dev/mapper/****-root
passed as a kernel argument.

** Important to remember this message **

11. Finally setup finishes.
The machine will restart and now it's time to boot it up.

12. First boot up.
Switch machine on again. When the logo appears press Del lots of times
until you get a PMON prompt.

Now boot up your machine like this (substiute your machine name for ****)

PMON> load (wd0,0)/vmlinux-3.5.3-gnu
PMON> initrd (wd0,0)/initrd.img-3.5.3-gnu
PMON> g console=tty no_auto_cmd machtype=8.9 root=/dev/****-root

13. My machine started but I didn't get a Graphical interface.

What happened to me was this. The machine started booting up, then 
there was a flashing cursor in the top left of the screen.
I pressed F4 and got a login prompt. Logged in, then as superuser i removed the 
siliconmotion driver. 

apt-get remove xserver-xorg-video-siliconmotion

14. Then I shut down the machine.
shutdown -h now

15. I restarted the machine and booted up.
(see number 12. above).

Now my machine is working :)

1. Boot
I will make it boot directly from PMON. I think I can do this by setting the al 
and karg variables.
I have already tried setting the variables at the PMON prompt like this:
PMON> set al (wd0,0)/vmlinux-3.5.3-gnu

2. External monitor
It works with an external monitor although its a bit blurry. What can I do? Do 
I need to change the resolution?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]