gnash-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-commit] gnash/server action.cpp gnash.h


From: Vitaly Alexeev
Subject: [Gnash-commit] gnash/server action.cpp gnash.h
Date: Mon, 12 Jun 2006 17:23:31 +0000

CVSROOT:        /sources/gnash
Module name:    gnash
Changes by:     Vitaly Alexeev <alexeev>        06/06/12 17:23:31

Modified files:
        server         : action.cpp gnash.h 

Log message:
        add register_component(...)

CVSWeb URLs:
http://cvs.savannah.gnu.org/viewcvs/gnash/server/action.cpp?cvsroot=gnash&r1=1.81&r2=1.82
http://cvs.savannah.gnu.org/viewcvs/gnash/server/gnash.h?cvsroot=gnash&r1=1.30&r2=1.31

Patches:
Index: action.cpp
===================================================================
RCS file: /sources/gnash/gnash/server/action.cpp,v
retrieving revision 1.81
retrieving revision 1.82
diff -u -b -r1.81 -r1.82
--- action.cpp  8 Jun 2006 04:16:19 -0000       1.81
+++ action.cpp  12 Jun 2006 17:23:30 -0000      1.82
@@ -167,6 +167,12 @@
 smart_ptr<as_object>   s_global;
 fscommand_callback     s_fscommand_handler = NULL;
 
+void register_component(const tu_stringi& name, as_c_function_ptr handler)
+{
+       action_init();
+       assert(s_global != NULL);
+       s_global->set_member(name, handler);
+}
 
 #define EXTERN_MOVIE
        

Index: gnash.h
===================================================================
RCS file: /sources/gnash/gnash/server/gnash.h,v
retrieving revision 1.30
retrieving revision 1.31
diff -u -b -r1.30 -r1.31
--- gnash.h     27 May 2006 18:20:28 -0000      1.30
+++ gnash.h     12 Jun 2006 17:23:30 -0000      1.31
@@ -53,6 +53,8 @@
 
 #include "ref_counted.h" // for bitmap_info inheritance
 
+#include "as_value.h" // for register_component(...)
+
 // FIXME: The local usage of these constants should probably be renamed in this
 // file because they conflict with definitions in the system header files. 
Luckily
 // they are used in files we don't need, so we should be able to safely 
redefine
@@ -143,6 +145,9 @@
 /// script to fscommand().
 void   register_fscommand_callback(fscommand_callback handler);
 
+/// Use this to register gnash extension
+void register_component(const tu_stringi& name, as_c_function_ptr handler);
+
 /// Use this to control how finely curves are subdivided.  1.0
 /// is the default; it's a pretty good value.  Larger values
 /// result in coarser, more angular curves with fewer vertices.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]