[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] build failure on x86_64 linux

From: Camm Maguire
Subject: Re: [Gcl-devel] build failure on x86_64 linux
Date: Thu, 25 Jun 2009 13:16:19 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

Greetings, and thanks so much for your report!

I'd like to chae down the cvs issue, but to get going quickly I'd like
to make sure you are using the 2.6.8pre cvs branch.

My apologies for this somewhat sscatterred state of affairs, but here
is the GCL development convention:

x.y.z, y even -- stable series
       y odd  -- development series

2.6.8 will be the next stable release.  It really should have been
released some time ago.  2.7.0, aka cvs HEAD, is the development
snapshot and can experience breakages from time to time.

To get 2.6.8pre, which is the branch that will be tagged as 2.6.8 when
released, do

cvs -z9 -q -d:pserver:address@hidden:/sources/gcl \
     co -d gcl-2.6.8pre -r Version_2_6_8pre gcl

To get cvs head, do

cvs -z9 -q -d:pserver:address@hidden:/sources/gcl \
     co -d gclcvs-2.7.0 gcl

Finally, the Debian packages labeled 2.6.7-??? are actually 2.6.8pre
snapshots.  This is to ensure that 2.6.8 will compile on all
architectures supporting all applications before final release.

Please let me know if problems persist.

Take care,

Wolfgang Pichl <address@hidden> writes:

> Hi,
> I am trying to build gcl on x86_64 Linux (SLAMD64 distribution). I had
> any kind of weird problems configuring and compiling the stable
> 2.6.7. After applying 2 patches from Fedora and switching off brk
> randomization in /proc/sys/kernel, I got at least 'configure' to
> work. 'Make' had a problem linking libbfd.a, because the version I
> have requires to link with libz. This could be solved by adding the
> linker flag -lz in makedefc and makedefs, but finally compilation
> ended with a segmentation fault.
> Therefore I decided to use the CVS. This worked much better, but
> finally also failed.
> The tool I am using:
> gcc version: 4.2.4
> binutils:    2.18.50
> glibc:       2.7
> These are my configure options:
> ./configure --libdir=/usr/local/lib64 --enable-readline --enable-ansi
> --enable-xgcl --enable-tkconfig=/usr/lib64
> --enable-tclconfig=/usr/lib64
> Configure worked without any problem, however, after a long
> compilation 'make' ended up with the following error:
> Pass1 signature discovery on 1095 functions ...
>         ...) is being compiled.
> ;; Warning: arg type mismatch in auto-proclamation (T T STRUCTURE-CLASS
>                                                     T T) -> (T T T T T)
>          ...) is being compiled.
> ;; Warning: arg type mismatch in auto-proclamation (T T PCL::STD-CLASS
>                                                     T T) -> (T T T T T)
> Error:
> Fast links are on: do (si::use-fast-links nil) for debugging
> Signalled by LET.
> Broken at LET.  Type :H for Help.
> 1 (Continue) Retry compiling (CONDITIONS::|(PCL::FAST-METHOD
>                                   NIL).
> 2 Return to top level.
> COMMON-LISP-USER>>make[1]: *** [final] Error 255
> rm recompile.h pre_init.lsp post_init.lsp
> make[1]: Leaving directory `/usr/local/src/gcl/unixport'
> make: *** [system] Error 2
> Can anybody help me?
> N.B. I posted this already yesterday, but obviously too early (after
> subscribing, but before receiving the confirmation mail). Obviously my
> first post has been ignored (as it should). Anyway, please excuse, if
> this
> should appear doubly on the list.
> Best regards
> Wolfgang Pichl
> _______________________________________________
> Gcl-devel mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/gcl-devel

Camm Maguire                                        address@hidden
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]