[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] cvs make on redhat 5.0

From: Jim Ward
Subject: Re: [Gcl-devel] cvs make on redhat 5.0
Date: Tue, 23 Jun 2009 10:36:56 -0600
User-agent: Internet Messaging Program (IMP) H3 (4.2.1-RC1)

reply vs reply-all.  sorry about that.

There is an error in the spec file.  Needed to remove the "%patch5 -p1"  line.
Just for sanity, I commented out the /usr/local, until I knew it would complete.
There rpmbuild -ba worked, compiled, failed to build packages.
attached is the bottom part of the build and errors. Mostly it appears to want all the .c .h files but can't find them or doesn't need them, not sure. I'm an SysAdmin that still likes make and hacks source files. rpmbuild is still a little like magic to me.

On the up side, gcl 2.6.8 does work. I went into /usr/src/redhat/BUILD/gcl-2.6.8 found everything. ./configure; make; make install and it was happy and worked. acl2 v3.5 compiled using it.

I'm willing to continue to try and get rpm files, if you are.

Jim Ward

A man has made at least a start on discovering the meaning of human
life when he plants shade trees under which he knows full well he
will never sit.
                - Elton Trueblood

Quoting Jerry James <address@hidden>:

Let's keep the list involved, in case someone else has a similar
question/problem later.

On Tue, Jun 23, 2009 at 9:36 AM, Jim Ward<address@hidden> wrote:
Ok, made the changes, looks like gcl built, but now I build errors looks
like for selinux.  selinux is disable (but installed) on our systems (to
much a pain).  How can I disable selinux part, partial output below.

Okay, so we need to rip the SELinux parts out, too.  Result attached.

Oh and before I forget, does this install into /usr/local or /usr?  I would
really like to avoid installing gcl on about 70+ linux machines and just
install it once into /usr/local.

Hmmmmm.....  Well, rpm builds for /usr by default.  I can think of two
ways to try addressing this.  First, maybe we can just define _prefix
to /usr/local in the spec file.  I've added that to the attached
version, but I don't know if it will work.  However, now you have an
RPM-managed package in /usr/local, which doesn't seem like a good
thing.  The second approach to try is to only do the "rpmbuild -bp"
part to get the patches applied, etc., then manually configure and
build following the recipe in the spec file so that you can control
the resulting install prefix.

And did I say THANKS!!!!!

You are very welcome.
Jerry James

Attachment: gcl268builderror.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]